Ardour2 beta 8 Plugins Crash


I’ve only recently downloaded Ardour. I was using the stable version and decided to have a play around with the latest Ardour2 beta.

When I select plugins in Ardour2, however, it just seems to crash and then Jack Pilot stops working and I have to restart my computer to get Jack running again.

After restarting my computer, I can start Jack Pilot and qjackctrl again with the stable version and everything works okay.

I haven’t read any posts about other people having the same problem, although I realise it’s a beta. Can anyone tell me what the problem could be? I’m using a mac by the way.


A slight correction on my previous post:

It seems that I can add a plugin into the signal path, but it’s when I click on Activate that the crash occurs.

Also, when Ardour has crashed and Jack stops working, if I then close Jack and open one of my other music DAWs without restarting my computer, I get no sound from them. It seems that they too are trying to route their audio through Jack - so I try switching my preferences for the specific application back to my M-Audio Duo (Interface), but still no sound, unless I restart my computer.

I’ve only started using Jack since downloading Ardour and still haven’t made it my default when running my other audio applications. Anyhow, if I can get this problem sorted out and when I’ve configured Jack properly for different sessions, I’ll probably use it much more.

Any help would be much appreciated.

you’re using jackpilot -and- qjackctl? simultaneously?

Yes. Is that the wrong thing to do?

It’s because when I’ve tried starting qjackctl I get an error message saying it couldn’t start. If I start Jack Pilot first though, then I can run qjackctl.

However, I just tried starting qjcakctl on it’s own, AFTER opening Ardour and it started. Still got the crash after trying to activate a plugin though!

But I thought you had to start Jack before opening your applications.

Forgive me if I sound clueless - maybe it’s the way I’ve set up qjackctl that’s causing the problems, it’s new to me though, so I don’t know.

It would hep if you send log files:

  • Ardour and jack crash log that should be in your account Library/Logs/CrashReporter/ folder

  • the context of the console file: open it in /Applications/Utilities/ before starting Ardour and send the context after the crash

Here they are:

Ardour and Jack Crash Log

Date/Time: 2006-11-16 21:02:31.920 +0000
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: ardour
Path: /Applications/
Parent: Ardour2 [423]

Version: ??? (389)

PID: 424
Thread: 8

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x0402d000

Thread 0:
0 libSystem.B.dylib 0x9001f08c select + 12
1 libglib-2.0.0.dylib 0x00da3990 g_poll + 376 (icplusplus.c:28)
2 libglib-2.0.0.dylib 0x00daa290 g_main_context_iterate + 1376 (icplusplus.c:28)
3 libglib-2.0.0.dylib 0x00daa7b0 g_main_loop_run + 840 (icplusplus.c:28)
4 libgtk-x11-2.0.0.dylib 0x022f90f0 gtk_main + 332 (icplusplus.c:28)
5 libgtkmm2ext.dylib 0x00c0f6dc Gtkmm2ext::UI::run(Receiver&) + 120 (icplusplus.c:28)
6 ardour 0x001098dc main + 2404 (crt.c:355)
7 ardour 0x00002e68 _start + 348 (crt.c:272)
8 ardour 0x00002d08 start + 60

Thread 1:
0 libSystem.B.dylib 0x90040978 mach_wait_until + 8
1 libSystem.B.dylib 0x90040744 nanosleep + 388
2 libglib-2.0.0.dylib 0x00dd3dbc g_usleep + 96 (icplusplus.c:28)
3 libardour.dylib 0x0181c070 ARDOUR::AudioEngine::meter_thread() + 36 (icplusplus.c:28)
4 libglibmm2.dylib 0x02e5a7f0 call_thread_entry_slot + 24 (icplusplus.c:28)
5 libglib-2.0.0.dylib 0x00dcfbac g_thread_create_proxy + 644 (icplusplus.c:28)
6 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 2:
0 libSystem.B.dylib 0x9000ab48 mach_msg_trap + 8
1 libSystem.B.dylib 0x9000aa9c mach_msg + 60
2 0x96adeac8 XServerMachPort::ReceiveMessage(int&, void*, int&) + 84
3 0x96ad1c80 MIDIInPortThread::Run() + 64
4 0x96ad5f44 XThread::RunHelper(void*) + 28
5 0x96adf87c CAPThread::Entry(CAPThread*) + 96
6 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 3:
0 libSystem.B.dylib 0x900c73c0 poll + 12
1 libardour.dylib 0x018b7c4c ARDOUR::OSC::osc_receiver() + 220 (icplusplus.c:28)
2 libardour.dylib 0x018b7de8 ARDOUR::OSC::_osc_receiver(void*) + 16 (icplusplus.c:28)
3 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 4:
0 libSystem.B.dylib 0x900c73c0 poll + 12
1 libardour.dylib 0x0182c610 ARDOUR::AudioSource::peak_thread_work(void*) + 332 (icplusplus.c:28)
2 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 5:
0 libSystem.B.dylib 0x900c73c0 poll + 12
1 libardour.dylib 0x0189177c ARDOUR::Session::butler_thread_work() + 84 (icplusplus.c:28)
2 libardour.dylib 0x018921b0 ARDOUR::Session::_butler_thread_work(void*) + 156 (icplusplus.c:28)
3 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 6:
0 libSystem.B.dylib 0x900c73c0 poll + 12
1 libardour.dylib 0x0189a5cc ARDOUR::Session::midi_thread_work() + 796 (icplusplus.c:28)
2 libardour.dylib 0x0189a970 ARDOUR::Session::_midi_thread_work(void*) + 52 (icplusplus.c:28)
3 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 7:
0 libSystem.B.dylib 0x900c73c0 poll + 12
1 libjack.0.dylib 0x032c6eb0 jack_client_thread + 224 (client.c:1270)
2 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 8 Crashed:
0 <<00000000>> 0xffff86bc __bzero + 188 (cpu_capabilities.h:187)
1 libardour.dylib 0x01857390 ARDOUR::IO::pan(std::vector<float*, std::allocator<float*> >&, unsigned, unsigned, unsigned, float) + 664 (icplusplus.c:28)
2 libardour.dylib 0x018780dc ARDOUR::Route::process_output_buffers(std::vector<float*, std::allocator<float*> >&, unsigned, unsigned, unsigned, unsigned, unsigned, bool, int, bool) + 3472 (icplusplus.c:28)
3 libardour.dylib 0x01818674 ARDOUR::AudioTrack::passthru_silence(unsigned, unsigned, unsigned, unsigned, int, bool) + 120 (icplusplus.c:28)
4 libardour.dylib 0x0181a134 ARDOUR::AudioTrack::no_roll(unsigned, unsigned, unsigned, unsigned, bool, bool, bool) + 464 (icplusplus.c:28)
5 libardour.dylib 0x0189af90 ARDOUR::Session::no_roll(unsigned, unsigned) + 464 (icplusplus.c:28)
6 libardour.dylib 0x0189c184 ARDOUR::Session::process_without_events(unsigned) + 212 (icplusplus.c:28)
7 libardour.dylib 0x0189c4a4 ARDOUR::Session::process_with_events(unsigned) + 300 (icplusplus.c:28)
8 libardour.dylib 0x0189c35c ARDOUR::Session::process(unsigned) + 168 (icplusplus.c:28)
9 libardour.dylib 0x0181da8c ARDOUR::AudioEngine::process_callback(unsigned) + 184 (icplusplus.c:28)
10 libjack.0.dylib 0x032c7834 jack_client_process_thread + 176 (client.c:1605)
11 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 8 crashed with PPC Thread State 64:
srr0: 0x00000000ffff86bc srr1: 0x100000000200f030 vrsave: 0x0000000000000000
cr: 0x24000004 xer: 0x0000000020000000 lr: 0x0000000001857390 ctr: 0x0000000000000020
r0: 0x0000000000000000 r1: 0x00000000f04078b0 r2: 0x0000000000000002 r3: 0x000000000402d000
r4: 0x0000000000000000 r5: 0x0000000000000000 r6: 0x0000000000000400 r7: 0x0000000000000000
r8: 0x0000000000000020 r9: 0x000000000402d000 r10: 0x00000000901b9f58 r11: 0x00000000019ebec8
r12: 0x0000000090129ac0 r13: 0x0000000000000400 r14: 0x0000000000000000 r15: 0x0000000000000000
r16: 0x0000000000000000 r17: 0x0000000000000000 r18: 0x0000000000000000 r19: 0x00000000f04078d0
r20: 0x0000000000000002 r21: 0x00000000038eedc4 r22: 0x00000000f04078f0 r23: 0x0000000000000000
r24: 0x0000000003907e00 r25: 0x0000000000000400 r26: 0x0000000000001000 r27: 0x0000000003907e78
r28: 0x00000000f0407910 r29: 0x0000000000000004 r30: 0x00000000f04078d0 r31: 0x0000000001857108

Binary Images Description:
0x1000 - 0x46ffff ardour /Applications/
0xaaa000 - 0xab3fff libardour_cp.dylib /Applications/
0xac3000 - 0xacbfff libintl.3.dylib /Applications/
0xadf000 - 0xae0fff libgmodule-2.0.0.dylib /Applications/
0xae3000 - 0xae5fff libgthread-2.0.0.dylib /Applications/
0xae9000 - 0xafbfff libz.1.dylib /Applications/
0xc05000 - 0xc44fff libgtkmm2ext.dylib /Applications/
0xcdc000 - 0xcf5fff libmidi++.dylib /Applications/
0xd1c000 - 0xd3ffff libpbd.dylib /Applications/
0xd7a000 - 0xe21fff libglib-2.0.0.dylib /Applications/
0xe3c000 - 0xf12fff libiconv.2.dylib /Applications/
0xf48000 - 0xf85fff libgobject-2.0.0.dylib /Applications/
0xf96000 - 0xfa7fff libart_lgpl_2.2.dylib /Applications/
0xfd9000 - 0xff3fff libatk-1.0.0.dylib /Applications/
0x1808000 - 0x19eafff libardour.dylib /Applications/
0x1c9c000 - 0x1de1fff libgtkmm2.dylib /Applications/
0x2054000 - 0x2076fff libgnomecanvas-2.0.dylib /Applications/
0x20fe000 - 0x2122fff libpangoft2-1.0.0.dylib /Applications/
0x2194000 - 0x25e2fff libgtk-x11-2.0.0.dylib /Applications/
0x26b6000 - 0x2759fff libgdk-x11-2.0.0.dylib /Applications/
0x277e000 - 0x2799fff libgdk_pixbuf-2.0.0.dylib /Applications/
0x27a1000 - 0x27eafff libtiff.3.dylib /Applications/
0x2872000 - 0x288efff libjpeg.62.dylib /Applications/
0x2895000 - 0x289afff libpangocairo-1.0.0.dylib /Applications/
0x28ae000 - 0x28dffff libpango-1.0.0.dylib /Applications/
0x293f000 - 0x298cfff libcairo.2.dylib /Applications/
0x2a9b000 - 0x2af3fff libfreetype.6.dylib /Applications/
0x2c41000 - 0x2c61fff libfontconfig.1.dylib /Applications/
0x2cbd000 - 0x2cf0fff libpng12.0.dylib /Applications/
0x2cf8000 - 0x2cfefff libXrender.1.dylib /Applications/
0x2d4a000 - 0x2d6bfff libgnomecanvasmm.dylib /Applications/
0x2daa000 - 0x2df0fff libsndfile-ardour.dylib /Applications/
0x2e34000 - 0x2e38fff liblrdf.2.dylib /Applications/
0x2e4b000 - 0x2e7cfff libglibmm2.dylib /Applications/
0x2ece000 - 0x2edffff libpangomm.dylib /Applications/
0x2f00000 - 0x2f27fff libatkmm.dylib /Applications/
0x2f5a000 - 0x2f7efff libgdkmm2.dylib /Applications/
0x2fbb000 - 0x2fbdfff libsigc++2.dylib /Applications/
0x2fc3000 - 0x30bafff libxml2.2.dylib /Applications/
0x32b3000 - 0x32bbfff libsoundtouch.dylib /Applications/
0x32c4000 - 0x32cdfff libjack.0.dylib /usr/local/lib/libjack.0.dylib
0x32fe000 - 0x3329fff libraptor.1.dylib /Applications/
0x33b4000 - 0x33edfff libssl.0.9.8.dylib /Applications/
0x3404000 - 0x34fdfff libcrypto.0.9.8.dylib /Applications/
0x3569000 - 0x3586fff libexpat.1.dylib /Applications/
0x3799000 - 0x379afff /Applications/
0x37a4000 - 0x37b9fff /Applications/
0x402d000 - 0x402dfff /Library/Audio/Plug-Ins/LADSPA/
0x4031000 - 0x4034fff /Library/Audio/Plug-Ins/LADSPA/
0x4041000 - 0x4042fff /Library/Audio/Plug-Ins/LADSPA/
0x4047000 - 0x4047fff /Library/Audio/Plug-Ins/LADSPA/
0x404b000 - 0x404dfff /Library/Audio/Plug-Ins/LADSPA/
0x4055000 - 0x4057fff /Library/Audio/Plug-Ins/LADSPA/
0x405d000 - 0x405ffff /Library/Audio/Plug-Ins/LADSPA/
0x4066000 - 0x4067fff /Library/Audio/Plug-Ins/LADSPA/
0x406c000 - 0x406dfff /Library/Audio/Plug-Ins/LADSPA/
0x4072000 - 0x4075fff /Library/Audio/Plug-Ins/LADSPA/
0x407e000 - 0x40a8fff /Library/Audio/Plug-Ins/LADSPA/
0x40db000 - 0x40dcfff /Library/Audio/Plug-Ins/LADSPA/
0x40e1000 - 0x40f8fff /Library/Audio/Plug-Ins/LADSPA/
0x4116000 - 0x4116fff /Library/Audio/Plug-Ins/LADSPA/
0x411b000 - 0x411efff /Library/Audio/Plug-Ins/LADSPA/
0x412a000 - 0x412afff /Library/Audio/Plug-Ins/LADSPA/
0x412f000 - 0x412ffff /Library/Audio/Plug-Ins/LADSPA/
0x4133000 - 0x4133fff /Library/Audio/Plug-Ins/LADSPA/
0x4137000 - 0x4137fff /Library/Audio/Plug-Ins/LADSPA/
0x413b000 - 0x413cfff /Library/Audio/Plug-Ins/LADSPA/
0x4141000 - 0x4142fff /Library/Audio/Plug-Ins/LADSPA/
0x4146000 - 0x4147fff /Library/Audio/Plug-Ins/LADSPA/
0x414b000 - 0x414dfff /Library/Audio/Plug-Ins/LADSPA/
0x4157000 - 0x4159fff /Library/Audio/Plug-Ins/LADSPA/
0x4160000 - 0x4161fff /Library/Audio/Plug-Ins/LADSPA/
0x4165000 - 0x4166fff /Library/Audio/Plug-Ins/LADSPA/
0x416b000 - 0x416dfff /Library/Audio/Plug-Ins/LADSPA/
0x4175000 - 0x4176fff /Library/Audio/Plug-Ins/LADSPA/
0x417b000 - 0x417dfff /Library/Audio/Plug-Ins/LADSPA/
0x4184000 - 0x4185fff /Library/Audio/Plug-Ins/LADSPA/
0x418a000 - 0x418bfff /Library/Audio/Plug-Ins/LADSPA/
0x4191000 - 0x4192fff /Library/Audio/Plug-Ins/LADSPA/
0x4198000 - 0x419afff /Library/Audio/Plug-Ins/LADSPA/
0x41a1000 - 0x41a1fff /Library/Audio/Plug-Ins/LADSPA/
0x41a5000 - 0x41a5fff /Library/Audio/Plug-Ins/LADSPA/
0x41a9000 - 0x41aafff /Library/Audio/Plug-Ins/LADSPA/
0x41af000 - 0x41b0fff /Library/Audio/Plug-Ins/LADSPA/
0x41b6000 - 0x41b7fff /Library/Audio/Plug-Ins/LADSPA/
0x41bc000 - 0x41c0fff /Library/Audio/Plug-Ins/LADSPA/
0x41cc000 - 0x41cdfff /Library/Audio/Plug-Ins/LADSPA/
0x41d2000 - 0x41e2fff /Library/Audio/Plug-Ins/LADSPA/
0x41f9000 - 0x41fcfff /Library/Audio/Plug-Ins/LADSPA/
0x4205000 - 0x4205fff /Library/Audio/Plug-Ins/LADSPA/
0x420a000 - 0x420bfff /Library/Audio/Plug-Ins/LADSPA/
0x4210000 - 0x4217fff /Library/Audio/Plug-Ins/LADSPA/
0x4227000 - 0x4227fff /Library/Audio/Plug-Ins/LADSPA/
0x433f000 - 0x4341fff /Library/Audio/Plug-Ins/LADSPA/
0x4347000 - 0x4347fff /Library/Audio/Plug-Ins/LADSPA/
0x434b000 - 0x434bfff /Library/Audio/Plug-Ins/LADSPA/
0x434f000 - 0x434ffff /Library/Audio/Plug-Ins/LADSPA/
0x4353000 - 0x4353fff /Library/Audio/Plug-Ins/LADSPA/
0x4357000 - 0x4358fff /Library/Audio/Plug-Ins/LADSPA/
0x435f000 - 0x4361fff /Library/Audio/Plug-Ins/LADSPA/
0x4367000 - 0x4368fff /Library/Audio/Plug-Ins/LADSPA/
0x436e000 - 0x436efff /Library/Audio/Plug-Ins/LADSPA/
0x4372000 - 0x4373fff /Library/Audio/Plug-Ins/LADSPA/
0x4378000 - 0x4378fff /Library/Audio/Plug-Ins/LADSPA/
0x437c000 - 0x437cfff /Library/Audio/Plug-Ins/LADSPA/
0x4380000 - 0x4381fff /Library/Audio/Plug-Ins/LADSPA/
0x4388000 - 0x438afff /Library/Audio/Plug-Ins/LADSPA/
0x4391000 - 0x4393fff /Library/Audio/Plug-Ins/LADSPA/
0x439c000 - 0x439ffff /Library/Audio/Plug-Ins/LADSPA/
0x43a8000 - 0x43a8fff /Library/Audio/Plug-Ins/LADSPA/
0x43ad000 - 0x43adfff /Library/Audio/Plug-Ins/LADSPA/
0x43b1000 - 0x43b2fff /Library/Audio/Plug-Ins/LADSPA/
0x43ba000 - 0x43bbfff /Library/Audio/Plug-Ins/LADSPA/
0x43c1000 - 0x43c2fff /Library/Audio/Plug-Ins/LADSPA/
0x43c8000 - 0x43c9fff /Library/Audio/Plug-Ins/LADSPA/
0x43ce000 - 0x43d0fff /Library/Audio/Plug-Ins/LADSPA/
0x43d8000 - 0x43dafff /Library/Audio/Plug-Ins/LADSPA/
0x43e2000 - 0x43e4fff /Library/Audio/Plug-Ins/LADSPA/
0x43ec000 - 0x43eefff /Library/Audio/Plug-Ins/LADSPA/
0x43f7000 - 0x43f7fff /Library/Audio/Plug-Ins/LADSPA/
0x43fb000 - 0x43fbfff /Library/Audio/Plug-Ins/LADSPA/
0x4505000 - 0x45c4fff /Library/Audio/Plug-Ins/LADSPA/
0x462b000 - 0x462dfff /Library/Audio/Plug-Ins/LADSPA/
0x4636000 - 0x4638fff /Library/Audio/Plug-Ins/LADSPA/
0x4641000 - 0x4645fff /Library/Audio/Plug-Ins/LADSPA/
0x464d000 - 0x464efff /Library/Audio/Plug-Ins/LADSPA/
0x4654000 - 0x4654fff /Library/Audio/Plug-Ins/LADSPA/
0x4658000 - 0x4658fff /Library/Audio/Plug-Ins/LADSPA/
0x465c000 - 0x465cfff /Library/Audio/Plug-Ins/LADSPA/
0x4660000 - 0x4661fff /Library/Audio/Plug-Ins/LADSPA/
0x4666000 - 0x4666fff /Library/Audio/Plug-Ins/LADSPA/
0x466b000 - 0x466cfff /Library/Audio/Plug-Ins/LADSPA/
0x4671000 - 0x4672fff /Library/Audio/Plug-Ins/LADSPA/
0x4676000 - 0x4678fff /Library/Audio/Plug-Ins/LADSPA/
0x467c000 - 0x467dfff /Library/Audio/Plug-Ins/LADSPA/
0x4688000 - 0x468afff /Library/Audio/Plug-Ins/LADSPA/
0x468d000 - 0x468ffff /Library/Audio/Plug-Ins/LADSPA/
0x4692000 - 0x4695fff /Library/Audio/Plug-Ins/LADSPA/
0x4698000 - 0x4699fff /Library/Audio/Plug-Ins/LADSPA/
0x469c000 - 0x469ffff /Library/Audio/Plug-Ins/LADSPA/
0x46a2000 - 0x46a5fff /Library/Audio/Plug-Ins/LADSPA/
0x46a8000 - 0x46a9fff /Library/Audio/Plug-Ins/LADSPA/
0x46ac000 - 0x46adfff /Library/Audio/Plug-Ins/LADSPA/
0x46b0000 - 0x46b2fff /Library/Audio/Plug-Ins/LADSPA/
0x46b6000 - 0x46b7fff /Library/Audio/Plug-Ins/LADSPA/
0x46bb000 - 0x46befff /Library/Audio/Plug-Ins/LADSPA/
0x46c5000 - 0x46c8fff /Library/Audio/Plug-Ins/LADSPA/
0x46cc000 - 0x46cdfff /Library/Audio/Plug-Ins/LADSPA/
0x46d0000 - 0x46d1fff /Library/Audio/Plug-Ins/LADSPA/
0x46d5000 - 0x46d6fff /Library/Audio/Plug-Ins/LADSPA/
0x46d9000 - 0x46dafff /Library/Audio/Plug-Ins/LADSPA/
0x46de000 - 0x46dffff /Library/Audio/Plug-Ins/LADSPA/
0x46e5000 - 0x46e6fff /Library/Audio/Plug-Ins/LADSPA/
0x46eb000 - 0x46edfff /Library/Audio/Plug-Ins/LADSPA/
0x46f4000 - 0x46f5fff /Library/Audio/Plug-Ins/LADSPA/
0x46fa000 - 0x46fbfff /Library/Audio/Plug-Ins/LADSPA/
0x4700000 - 0x4702fff /Library/Audio/Plug-Ins/LADSPA/
0x470c000 - 0x470cfff /Library/Audio/Plug-Ins/LADSPA/
0x4710000 - 0x4711fff /Library/Audio/Plug-Ins/LADSPA/
0x4716000 - 0x4716fff /Library/Audio/Plug-Ins/LADSPA/
0x475f000 - 0x4762fff /Applications/
0x4766000 - 0x476bfff /Applications/
0x8fe00000 - 0x8fe51fff dyld 45.3 /usr/lib/dyld
0x90000000 - 0x901bcfff libSystem.B.dylib /usr/lib/libSystem.B.dylib
0x90214000 - 0x90219fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
0x907ba000 - 0x90893fff 6.4.6 (368.27) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x908dc000 - 0x908dcfff 10.4 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x908de000 - 0x909e0fff libicucore.A.dylib /usr/lib/libicucore.A.dylib
0x90a3a000 - 0x90abefff libobjc.A.dylib /usr/lib/libobjc.A.dylib
0x90ae8000 - 0x90b5afff 1.4 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x90b70000 - 0x90b82fff libauto.dylib /usr/lib/libauto.dylib
0x90b89000 - 0x90e60fff 681.7 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x90ec6000 - 0x90f46fff 4.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x90f90000 - 0x90fd1fff 4.0 (129.18) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x90fe6000 - 0x90ffefff 1.1.2 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore
0x9100e000 - 0x9108ffff 1.0.5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x910d5000 - 0x910fefff 10.4.4 (121.36) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x91120000 - 0x912dbfff 4.5 (28992) /System/Library/Frameworks/Security.framework/Versions/A/Security
0x913d9000 - 0x913e2fff 2.1 /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x913e9000 - 0x91411fff 1.8.3 /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x91424000 - 0x9142ffff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib
0x91440000 - 0x914bbfff 3.0.4 /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x91a0d000 - 0x91ad5fff libcrypto.0.9.7.dylib /usr/lib/libcrypto.0.9.7.dylib
0x91cb8000 - 0x91cb8fff 1.2.2 (Accelerate 1.2.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x91cba000 - 0x91d9ffff 2.4 /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
0x91da7000 - 0x91dc6fff 3.2.2 (vecLib 3.2.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
0x91e32000 - 0x91ea0fff libvMisc.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
0x91eab000 - 0x91f40fff libvDSP.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
0x91f5a000 - 0x924e2fff libBLAS.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
0x92515000 - 0x92840fff libLAPACK.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
0x94148000 - 0x9420bfff 1.4.3 /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x9425d000 - 0x9425dfff 1.4 /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
0x94add000 - 0x94b4efff libstdc++.6.dylib /usr/lib/libstdc++.6.dylib
0x94bc1000 - 0x94be1fff libmx.A.dylib /usr/lib/libmx.A.dylib
0x94f0a000 - 0x94f39fff libssl.0.9.7.dylib /usr/lib/libssl.0.9.7.dylib
0x95655000 - 0x9567dfff libcurl.3.dylib /usr/lib/libcurl.3.dylib
0x95cd8000 - 0x95d01fff libxslt.1.dylib /usr/lib/libxslt.1.dylib
0x96ad1000 - 0x96b10fff 1.5 (41) /System/Library/Frameworks/CoreMIDI.framework/Versions/A/CoreMIDI
0x9a553000 - 0x9a562fff libICE.6.dylib /usr/X11R6/lib/libICE.6.dylib
0x9a568000 - 0x9a56dfff libSM.6.dylib /usr/X11R6/lib/libSM.6.dylib
0x9b569000 - 0x9b574fff libXext.6.dylib /usr/X11R6/lib/libXext.6.dylib
0x9b579000 - 0x9b641fff libX11.6.dylib /usr/X11R6/lib/libX11.6.dylib
0x9b997000 - 0x9b998fff libXinerama.1.dylib /usr/X11R6/lib/libXinerama.1.dylib
0x9b9cb000 - 0x9b9ccfff libXrandr.2.dylib /usr/X11R6/lib/libXrandr.2.dylib

The console log:

ardour: [INFO]: Apple VecLib H/W specific optimizations in use
ardour: [ERROR]: LADSPA: cannot load module “/Library/Audio/Plug-Ins/LADSPA/” (dlopen(/Library/Audio/Plug-Ins/LADSPA/, 2): no suitable image found. Did find:
/Library/Audio/Plug-Ins/LADSPA/ mach-o, but wrong architecture)
ardour: [ERROR]: LADSPA: cannot load module “/Library/Audio/Plug-Ins/LADSPA/” (dlopen(/Library/Audio/Plug-Ins/LADSPA/, 2): no suitable image found. Did find:
/Library/Audio/Plug-Ins/LADSPA/ mach-o, but wrong architecture)
ardour: [ERROR]: LADSPA: cannot load module “/Library/Audio/Plug-Ins/LADSPA/” (dlopen(/Library/Audio/Plug-Ins/LADSPA/, 2): no suitable image found. Did find:
/Library/Audio/Plug-Ins/LADSPA/ mach-o, but wrong architecture)

it may not be the cause of your problem; but, you don’t need to run jackpilot and qjackctl together. they are both GUI frontends to jack. i think that you weren’t able to connect to jack with qjackctl without using jackpilot because the path specified in qjackctl for the jackd executable was incorrect. it was incorrect for me, as well, when first using the OS X port.

you simply need to point qjackctl to the correct location of the executable. no point in running multiple frontends to the same daemon. (besides, qjackctl has a much more intuitive way of making connections.)

Thanks for that. I did think it seemed strange running them both.

I found a page on the Jack OS X yahoo discussion group that mentioned to
change server path to:


It works now. Still have the plugin crash problem though.

I seem to be having the same problem, with my 1.8 G5 iMac. However everything seems to be running fine so far on osx86 machine.

What plugin are you trying to insert? Does this happen for every plugin you try?


It seems to happen on every plugin I try.

Same here. Every plugin loads in. Double clicking on it even shows the plugin, but as soon as you disengage the bypass Ardour crashes.

Hi. I have the same problem (Ardour crash when activing plugins), on Ibook G4-PPC and OSX 10.4.8

I see at least 2 different problems:

  • some plug-ins are not compiled in Universal Binary mode
    For example SWH ones (latest version 0.4.15) contains 3 Intel only plus-ins (,, This can be seen using the “Get info” command. Ardour (correctly) refuse to load them at launch time.

  • them activating the ones that load crash with the following problem:

Symbol not found: __Z23AudioGetCurrentHostTimev
Referenced from: /Applications/
Expected in: flat namespace

Ok. So I checked my plugins folder for one which is Universal Binary, in this case Phasers.

Then I opened Ardour and tried the Phaser plugin and it still crashed.

So does this mean that any Intel-only plugins will have to be removed from the plugins folder if your on a PPC?

I’m slightly concerned now - are developers already stopping Universal Binary and just developing for Intel? Will we still be able to run future releases of Ardour on a PPC, but as long as we only use Universal Binary plugins?

I got the same behaviour

After load the plugin (every plugin) and activate it Ardour crashes.

I use JackPilot 1.6.0, JACK 0.101.3 with Jack Router version 0.8.3 on OSX 10.4.8 (Powerbook G4 12").

Thanks in advance (and thanks for this amazing piece of soft).