Ardour - your system has a limit for maximum amount of locked memory

i’m getting an error everytime i launch ardour about memory limit. i have used ardour before also and to overcome this problem i edited /etc/security/limits.conf, added a line @audio - memlock unlimited, then created a file in /etc/pam.d/common-session, and added a line session required it worked everytime. but this time its not working.

ulimit -l



after all this still get error

there’s also the path /etc/security/limits.d/ to check for limits settings

Stupid question, is your user part of the audio group? ANd have you logged out and back in since these changes?


yes i am in the audio group and i have restarted my laptop after making changes.

so should i change something there too… i dont understand i have done this before too it always worked, i dont what im doing wrong.

the only other place I know limits resources can apply is via systemd settings… and systemd is extremely versatile in this area if your distro is using them.

Are you on Arch Linux? Arch uses the ‘realtime’ group.

1 Like

On my system there is an application that put a folder in /etc/security/limits.d/ with a txt file that says something like @users memlock 1024. I’m not at my computer right now so I couldn’t say exactly what it is. I commented out that line. Look through any folders that are in /etc/security/limits.d/ for config files that might be changing your memlock settings.

1 Like

highly unlikely there are any sub-folders in this path, perhaps if you saw something as a “.txt” file then it is just a readme textfile. Configuration files are named “.conf” in this path and wouldn’t get parsed from sub-folders…

Right. Sorry I’m not at the computer. I will look into it when I am at home.

I have pam_limits in a number of files on my Ubuntu 18.04 system:

/etc/pam.d/cron:session    required
/etc/pam.d/lightdm:session required
/etc/pam.d/lightdm-autologin:session required
/etc/pam.d/lightdm-greeter:session required
/etc/pam.d/login:session    required
/etc/pam.d/runuser:session		required
/etc/pam.d/sshd:session    required
/etc/pam.d/su:session    required
/etc/pam.d/systemd-user:session  required

My guess is that whatever runs your login session isn’t including common-session

its working fine now. i did not do anything just recently updated the system there were some major updates systemd kernel and all its fixed now.

thanx everyone…

yes i am on arch linux.

I installed the package realtime-privileges. It adds a file


and adds your user to the ‘realtime’ group. I found for ALSA MIDI you also need to be in the ‘audio’ group. If it’s working it looks like your manual changes worked.

I’ve got a file that appeared in limits.d too :


I don’t know what put it there. Something I installed recently was VCV Rack. This file doesn’t affect the maximum amount of memory my user can lock. I did want to figure out what had put it there.

Yes. That is the file I was talking about. I commented out the line @users - memlock 1024 and the error went away.

I made a mistake. The file is actually called


gcr is a cryptographic package. ‘users’ is an obscure group that my user is not in, so it doesn’t affect my ulimit. ‘users’ seems to be a non-group – no-one should really be in it. It seems like a security thing, so I’m going to leave it.

the “users” group is no longer used in arch,

For some reason I must have been in the users group. When I commented out that line the error went away. I see that the better option would be to remove myself from users. In the Arch post about it, it says that those groups are no longer used but I am assuming that they still exist.

yes i installed this package too realtime-privilages. maybe this fixed my problem…