Ardour won't start anymore (Ubuntu 18.10)

Good evening folks, i’ve got an issue with Ardour 5.12.0, it used to startup and i would use it normally, but now it just won’t startup at all, here’s what i tried so far:

  • tried cleaning the ardour folders on /home/.cache and /home/.config;
  • tried starting it via the terminal with:
    “$ ardour” which returns “/usr/bin/ardour: 39: export: Desktop:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/user/.dotnet/tools: bad variable name”
    “/opt/ardour/bin/ardour-5.12.0” which returns “/opt/ardour/bin/ardour-5.12.0: error while loading shared libraries: cannot open shared object file: No such file or directory”
  • reinstalling it (using kxstudio repositories)

I also tried running ps aux | grep ardour, but the terminal doesn’t return any processes other than grep itself

I’m using Ubuntu 18.10

I’m in the middle of a game jam and i really need ardour to work again so i can finish the sound design, any help is heavily appreciated! :scream:Thank you very much in advance for your time!

That is likely the root cause (and the library path not being set results in a lot of follow up errors).

It seems there’s some whitespace or some umlaut character in a $PATH environment. Since it happens before Desktop, perhaps your user-name?

If you’re in a hurry, perhaps create a new user with a simple name e.g. “jam” and try to launch ardour as that user for now… and investigate later-- I’ll keep my fingers crossed.

hey thanks for the reply! i ended up just logging in as root and ardour started from the terminal normally. I’ll have a better look at this once i’m free and post a solution here. Weird tho… my username is just “User”…