Ardour will not play track

I am new to Ardour and Jack and cannot get Ardour to play anything. I am running Ubuntu 10.10 with Ardour 2.8.11. I used Synaptic to add all the Ubuntu-Studio packages. I had to remove Jackd2 and install Jackd1 before I could get Jack to start. Here is what I have done:

(1) Started Jack;
(2) started Ardour;
(3) imported a stereo .wav file;
(4) tried to play the .wav track.

I have tried using the play button on Transport menu, Transport > Play option from the main menu, Play from the pop-up menu from within the .wav track, Audition from the pop-up menu from within the .wav track, and probably a few more I can’t recall.

I have checked all the connections using Jack control. They were set up by Ardour and seem to be correct. They are:

(1) auditioner/out 1, click/out 1, master/out 1 --> playback_1;
(2) auditioner/out 2, click/out 2, master/out 2 --> playback_2;
(3) .wav track/out 1 --> master/in 1;
(4) .wav track/out 2 --> master/in 2;
(5) .wav/in 1 --> capture_1;
(6) .wav/in 2 --> capture_2.

I have tried to start the Transport on Jack control, and it starts and stops immediately with no messags in betwen. I keep getting XRUN callback messages with some number skipped, usually 46 or 47.

Since I am completely new to this, I presume I am overlooking some obvious item, but I have no idea how to get this thing working. I have used Audacity for years, and was hoping to add Ardour to my tool set. At this rate, that may be presumptive. Any suggestions would be appreciated.

My suggestion is going to be to get on IRC (Help>Chat) and seek help there. It sadly sounds like several different problems compounding on each other in this case and sorting through all of them may take time and is better spent on IRC.