Ardour v2 vs. v3 vs. v4

Hi all, I started with Ardour v2 and it worked great. recently downloaded v3.5, and I’ve been getting a lot of xruns. I noticed that v3.5 uses about twice the DSP as v2.

Any reason why this would be? I’m using Jack, so its configuration is a constant.


There was never any optimized release of Ardour 3.x from That’s one reason. Please use Ardour 4 from now on, too.

thanks, I just downloaded v4. still a lot of xruns compared to v2. I get virtually no xruns with the same Jack settings. Is v4 just more resource hungry?

What buffer/period size do you use with JACK? And what sample rate?

Oh, and how many CPU cores does your system have?

running 128 frames, 48k and 3 periods. 7 cores.

You face a conundrum. You are use a very small period size, and have lots of cores. By default, Ardour 3 and 4 will distribute processing across 6 of your 7 cores. This necessarily costs most in overhead than doing everything on a single core, but on the other hand, makes a lot more horsepower available. The extra overhead is most visible at small period sizes, and there is necessarily a tradeoff between these two.

So one thing to try is to go to Edit > Preferences > Misc > DSP CPU Utilitization and change that to just 1 processor. Then restart Ardour and see what happens.

7 cores? wow! If I may ask: what machine is that?

Is that really 7 full cores with 7 FPUs? or just hyperthreading. if the latter, tell ardour to only use actual cores that you have (most audio is floating point process and done on the FPU, hyperthreading does not help.)

I got an old dualcore, Echo Layla soundcard…Ardour 4 works fine here . 44 khz, 256 samples, and I use both cores for Ardour . What kind of soundcard do you use? Can that be the culprit?

I think I was wrong about the cores. the processor is an i7 Q740 1.73Ghz x4, so I guess it’s 4 cores.

I’m using a Tascam US800 USB interface

Again, what’s weird is that Ardour v2 works without any issues.

Ardour 2.x does not have any internal parallel DSP architecture. It can use only a single core for signal processing.

Is that advice on how many cores to use documented in any more detail somewhere? It’s not immediately obvious (to me, anyway) that using 1 core instead of many would produce an improvement in performance for some settings. I have a 6 core CPU, chosen partly because I knew that Ardour can make use of multiple cores, but now I’m wondering whether I’m putting it to best use. Not that I’m getting xruns, but if it would be good to know what the optimal settings were for a busy mix, or for an overdubbing session with minimal latency (which is affected by period sizes).

still getting xruns with 1 processor. they seem to be random, and the DSP % is relatively low, around 10%.

could something be running in the background that’s causing the xruns?

If you are having a bit of trouble with xruns that you cannot explain, lots of good advice here :
A tool to assist you with your system :

(Your distro’s package maintainers likely have it available for you.)

A running cron job, at job or timer (systemd) is worth checking for too. It may be as paul mentions - you might need to increase the period size.

The odd thing, though, is that popsongsmith doesn’t have the same xruns with Ardour 2, so it doesn’t look so much like a system settings problem. (though that can’t be ruled out, either)

Ardour 4 (and 3) is more complex than Ardour 2 ofcourse, When I switched from Ardour 2 to Ardour 3 I had the same “problem” with one core . Just use more cores and I think you’re happy to go!

My system runs on a plain Ubuntu 14.04 (64 bit) install with low latency kernel . Nothing fancy, really.

First of all, THANK YOU! to everyone who offered their help in trying to resolve this issue.

I realized this afternoon that I was in over my head in terms of trying to troubleshoot the xruns, so rather than continue to chase my tail, I simply downloaded Ubuntu Studio, and then upgraded to Ardour v4. All I can say is WOW. What a difference.

The Ardour/Jack DSP meter in Mint was up around 10-20%, but in Ubuntu Studio, it’s in the 1-2% range. Xruns are completely gone as well.

I have no idea what the culprit was, but now it’s running like a Swiss watch.

Thanks again everyone!

So what OS/distro were you running before?

Mint 16

were you running a realtime kernel? in the audio group?

Those 2 will cause lots of problems.

Its generally better to use a distro thats setup for audio work than trying to set one up yourself, as far as i know mint is not configured with this kind of thing in mind.

I havnt used ubuntu studio in years but i moved to kx studio (not suing the kde desktop but lxde instead) and its been solid.