Ardour through FreeNX or X -broadcast is snappy (in a bad way)


I have a headless Linux machine next to my Windows machine. I use it to run Linux apps through a FreeNX client or a Xwin (cygwin) -broadcast from my Windows machine.

However, the playhead is really annoying. It snaps a random position left or right of where you click 9 out of 10 times, but half of the times any edit (like “snap”) you make, does end up on the place where the playhead is supposed to be even though it’s not.
And pressing space for playback only works occasionally, other times it plays a few millisecs, not at all or from a totally different position. Also the playhead functions as a paintbrush, coloring everything red.

I was wondering, is there some kind of option, fix or other [insert anything] that makes Ardour play friendly through these kinds of remote logging in to Linux?

I run Windows 7 and Ubuntu 9.04.

I also tried Ardour on my Xubuntu 9.04 Mediacenter with a monitor attached and none of the above annoyances appear. But this machine is no good for anything other than playing some oldskool games.

I use FreeNX with a NoMachine client (on a normal ADSL line) and I do not experience this behaviour when doing the things you describe.

FreeNX does a lot of caching, compression and x roundtrip suppression.
Maybe its one of these settings causing the problem.


XDMCP works fine, although this is not the way I want to work because of the way my system is set up.

I have not yet got any clue where to look for the problem(s), but it seems to be like so:

  • No problem
  • X remote
  • No Problem (according to paul)
  • Xwin Remote
  • Problem!
  • NX Client (I use No!Machine, the only free one for Win I know and recommended by Ubuntu community)
  • Problem!

(how) Can I perform a X broadcast from another linux machine to test X.Org’s remote connection to this Ardour machine?

No. Ardour is designed to be used locally, and is not tested on things like FreeNX so I can’t comment on them really.

I am fairly sure I have used it before through a remote X session, but that is about it.


Seablade’s comment is not really that accurate. I have used Ardour remotely via X ( several times, and I know that it is used in at least a few institutions this way. I have never noticed, nor seen reports of the behaviour you are describing. You will have to take responsibility for further debugging this, since I know of no Ardour developer using FreeNX or Xwin.

I’ve been using ardour remotely through an xdmcp session all morning:), works great (especially with netjack)