Ardour Takes Over All Audio

Hi,

I have a System76 Galago Pro laptop running Pop!_OS 20.10, and running the regular subscriber version of Ardour. I had an online meeting yesterday and the other person couldn’t hear me and I couldn’t hear them. Zoom worked for me just fine before. I realized I had Ardour running in the background so I closed it and everything worked. I tried watching a youtube Ardour tutorial while running Ardour doesn’t work either. I figured out how to tell Ardour to ignore my laptop’s internal mic but is there a way to get it to share audio so I can at least watch youtube tutorials while also working with Ardour?

Thanks,
Christine

This is asked regularly.
Short answer: in the Audio/MIDI Setup window choose “pulseaudio” or “default” (i.e. not ALSA).
For a better answer, check for example Can't watch YouTube w/ Ardour Open - #4 by x42

Another solution would be to use the JACK backend instead of ALSA / pulseaudio. It is possible to set up a “pulseaudio bridge” so that applications like firefox that are only compatible with pulseaudio can still play audio while using JACK.

All of this can be fairly complicated if you’re new to linux audio. I would personally recommend to use Studio Controls to set this up. In general since you’re using Pop!_OS, you should be able to use ubuntu-studio packages, which include many audio applications / plugins.

Sorry for not responding earlier, my job has a way of taking over my life for days on end. That link you posted was very helpful. I now understand why Ardour wants to take over my sound card. I have enough experience using Linux that trying to mess with settings I don’t yet fully understand can end up with me having to spend hours fixing what I broke, although that is when I am forced to quickly learn a lot of stuff!

Conclusion: use my tablet to watch Ardour tutorials, and close Ardour when having Zoom meetings. Learn more about Linux audio.

Thanks!

Hi, I feel like I need to learn more about Linux audio before I go messing around with the settings. I’ve actually been blackboxing Linux audio for years and it’s about time I delve into it. I posted my temporary solutions in my other post in this topic.

Thanks!