Ardour Suddenly Can't Access Other Drives

When I start Ardour and attempt to create a new project, I get a window that says “Could not create session in (path): Session initialization failed”. Attached is a screenshot. This has not happened before and I’ve been using this second drive for Ardour sessions up until now with no issues.

Furthermore, if I try to open any of the sessions that I have stored on the second drive, the session will open but it will be in “read-only” mode.

I have tried uninstalling and reinstalling Ardour, and deleting the .config file to no avail. Help!

I will add that the only thing I’ve done that might have affected things is to install and run a program that’s supposed to delete any orphaned files on my computer. Did it wipe out something important?

Running Ubuntu 18.04.4 LTS.

Thanks,
Ivan!

vlcsnap-2019-09-14-14h15m39s954|630x433

Your other drive is mounted read-only.

If you don’t believe me, open a terminal, cd to somewhere on that drive, and type:

touch foo

If that works, I’m wrong and there’s some other problem in Ardour.

You’re absolutely right, I tried it and got a message that it’s read-only! I’ll have to tackle this from a different direction then, as it’s something with my configuration and not an Ardour problem. Thanks for setting me straight!

Ivan

Honestly, I don’t know about other Debian systems but Ubuntu has had weird issues with mounting drives and partitions for a few years now. The immediate fix is to run chmod -r 777 on the whole damn drive lol.

It’s a drive that Windows also had access to (the computer is dual-boot). I think (but it’s only a guess) that may have had a bearing on the issue since I booted into Windows for the first time in weeks yesterday. Anyway Windows didn’t have any business messing with the drive so I initiated operation Scorched Earth, backed up all my relevant files from the drive and then wiped it to EXT4 before putting my Linux stuff back onto it. Now everything is working perfectly again and I am very pleased!

Ivan

2 Likes