Ardour stops working after performing any operation while Audio setup is stopped

Since Ardour takes the sound away from all other applications, I often have to Start and Stop the Audio/MIDI Setup so I can go back and forth between applications.

That’s fine for me but sometimes I forget to start it back and I perform an operation (e.g. delete a track) and when I do that, the interface gets locked. I can’t do anything and have to kill the app and lose my unsaved work.

This happens quite often to me so I would really like if there was a way around this.

Operative System? version? Audio engine? Ardour version?

There should be a dialog popup:

“The current operation is not possible because of an error communicating with the audio hardware.”

and Ardour’s UI block until the message is acknowledged (it’s a modal dialog).
Could it be that this dialog is hidden behind some other window?

manjaro 20
Ardour 5.12.0
ALSA (is that what you mean by audio engine?)

1 Like

Nothing behind the window.
I’ll check in the closet…

I had a similar problem with other applications, solve using jack
Try and check if it is solved
there are applications that once stopped do not release the audio

I just tried:

  1. Create a new session, using the ALSA backend
  2. Add a track
  3. Window > Audio/MIDI Setup, stop the backend
  4. Try to delete the track (Track > Remove)


That is with Ardour 6.0.

Could it be that you’re running into a bug of 5.12 that has meanwhile been fixed?

PS. Ardour6 can also use Pulseaudio for playback, so if you’re only mixing or producing in the box without any live inputs this may be an option to share the soundcard.


I didn’t know 6.0 was out! lemme try…

Indeed, version 6.0 solves the issue! Thanks!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.