ardour slow since latest recording

Since the latest recording session with my ensemble Ardour reacts very slow. It sometimes refuses to playback.
Removing markers in Lokations takes 9-24 seconds, with task manager saying cpu 100%. Memory has 187 of 463MB used, it is a 512, does that mean the RAM is broken?
I tried session cleanup but if i “flush wastebasket” nothing happens and the all the files in Deadsounds are still there.
Any ideas?
Thank you!

i should mention that it is a pretty old box.
So it can well be it is near passing away…


I see lots of xrun markers. Did you allways get those or is it happening since Ardour reacts slow? Did you maybe change the buffer sizes in Jack? What are they set to? Did you maybe switch the CPU frequency governor from “performance” to “on demand”?

Hi thanks for the input!
The x-runs are usualy within the first second of the recording, i always got those.
I have not changed anything in jack. 1024 frames/period, 3 periods/buffer.
I dunno aboud the CPU frequency governor, where do i find that?

If you’re running on a laptop (and it looks like you are since there’s a battery icon in your panel) then you can tell your laptop to save more power by letting it idle the CPU at times when you’re on battery.

Where it is depends upon what GUI and OS you’re running, but it’s usually in System Settings (Ubuntu), Preferences (OS X) or Control Panel (some unix/linux distributions that try to be Windows-like), under Power or Power Management or Battery Life or something similar.

So if you changed some setup settings to try to make your battery last longer, that could do it.