Ardour SAE, JACK won't launch


I am using a first generation MacBook running Tiger. It worked with Ardour 2.1 and JACK 0.74, though there was some weirdness with Ardour hiding files somehow, which is documented in another thread.

I installed ArdourSAE after dutifully uninstalling Ardour 2.1 and JACK 0.74 for OSX. The Ardour2-SAE folder appeared in Applications; opening this folder reveals icons for JackPilot and Ardour2-SAE. Neither of these icons launch an application when double-clicked. I can see the little “Poof” visual effect on the icon, but nothing else. I tried installing JackOSX 0.81, and starting that, then trying to start Ardour. This didn’t work, so I uninstalled Jack again.

Then I tried to start Jack and Ardour from the command line, so I could view the error messages. I guess I don’t know the right commands to use. Here’s what the output looks like:

Last login: Sun Mar 1 11:37:11 on ttyp1
Welcome to Darwin!
paul-deshaws-computer:~ pad$ JackPilot
-bash: jackpilot: command not found
paul-deshaws-computer:~ pad$ jackd
-bash: jackd: command not found
paul-deshaws-computer:~ pad$ ardour2-sae
-bash: ardour2-sae: command not found
paul-deshaws-computer:~ pad$

Any suggestions what to try next?



Success! It works now. I still have to install Jack separately; it doesn’t seem to be included in SAE. Curiously, both the SAE and the regular version start up and run without Jack running, or even installed.


The SAE version definitely and absolutely includes JACK. It will, however, work with an already running version of JACK as long as its not an incompatible version (there have been a few).

I am not sure what you mean by “Curiously, both the SAE and the regular version start up and run without Jack running, or even installed.”

Would you please follow the instructions in the document referred to above for cases where ardour doesn’t work? At the very least, we need to see console output.

Did you read In full?

Actually, I did, but I just went back and re-read it. I see the problem: I didn’t run Software Update.

Running Software Update will very likely make Pro Tools unusable; DigiDesign recommends never doing it. Since I dual-boot Ubuntu Studio on this machine, I can just use the Linux version of Ardour. I’d like to try the simpler SAE interface, but it’s not essential.

[Edit] I used Apple’s Combo Updater to upgrade to 10.4.11; this is what DigiDesign recommends. Ardour still will not launch. I tried the SAE version, trashed it, reinstalled it, trashed it again, installed the full version, and tried it, too. Maybe I should go back to an earlier version?

Oddly enough, the Ardour SAE folder did not include Jack after I uninstalled and reinstalled it, so I installed Jack separately.

Any ideas? I would like to show off the shiny new Ardour OSX native to a friend who just bought a Macbook Pro for audio and video work.


The folder Ardour2.bin.crash.log shows the following (I don’t see anything in the console itself):
Host Name: paul-deshaws-computer
Date/Time: 2009-03-13 23:52:58.432 -0700
OS Version: 10.4.11 (Build 8S2167)
Report Version: 4

Command: Ardour2.bin
Path: /Applications/
Parent: WindowServer [61]

Version: 2.7.1/4296 (2.7.1/4296)

PID: 253
Thread: Unknown

Link (dyld) error:

Library not loaded: /usr/lib/libcurl.4.dylib
Referenced from: /Applications/…/Frameworks/libraptor.1.dylib
Reason: image not found

Using the ls command, I could find:

It looks like Combo Updater doesn’t install libcurl.4.dylib. Note that the Apple Intel First-time Users doc says to check for ibcurl1.4, not libcurl.4; this may be a typo. I Google-searched libcurl.4.dylib and found this:

Basically, backup everything, install a security update that will break Pro Tools, but there is a fix for that if I can remember my password to download it…looks like I need to wait until I have a few hours free.

–That Other Paul