Ardour reports "disk system was not able to keep up with Ardour" when moving MIDI note during looping of region

Since a while I get the message “The disk system on your computer was not able to keep up with Ardour” when I move a MIDI note whilest a region is looping.
The session contains 13 tracks, of which 2 are audio tracks, one set to inactive. The larger audio track is 7 seconds long, and the other tracks are only a few seconds long. Its just a playground session for experimenting on my way learning audio production.
When I set the second audio track inactive as well, the message does not show up anymore.
And that audio track is a rendered Zyn-Fusion track, so nothing special, and the disk is an SSD, so should easily be able to keep up with Ardour.

What might be the issue here?

Hi @Joysn71, I’m fairly new to Ardour, but maybe I can offer some general thoughts…
Do you have plenty of RAM headroom? Do you need to optimise the I/O buffer/cache?
What O/S are you using?

There was an error found recently that resulted in the end of a region being set beyond the end of the actual audio file. The “could not keep up” was the message triggered, but it really should be interpreted as “no audio data available when needed,” which in the case of this error is not because the disk is too slow but because the end of the audio file was reached so there is no more audio data available.

I do not believe the root cause of how that condition could occur was discovered yet, but the solution was to move the end of region just slightly backwards in time so that the region length was not longer than the audio file length.

Just speculating that the error caused the message you saw, but that seems likely.

My setup is running on a Linux Debian Trixie, the laptop has 32GB RAM with 7GB used, 9GB in buffers/cache and 15GB free according to top, no swap used and on file system level I set noatime and nodiratime to avoid unnecessary disk IO. The OS is running Firefox alongside the Cinnamon desktop and Ardour.
Besides this, I tuned the machine for low latency

This is likely a bug. I don’t have time to look at right now. Please file a report at tracker.ardour.org and attach a session archive to it, and let me know here when that’s done.

1 Like

Report is here: 0009697

Im getting quite a lot of these messages when using regionFx.
eg autotuning a word in a vocal
cut the word and playback loop it
region>Properties Region Fx
add autotune
apply
disk too slow msg

I feared that might happen on some machines. Region Fx are applied when reading data from disk, so in this case it is a valid report for once.

Hi, I am having the same problem when using the VST plugin YSFX (a wrapper for JSFX plugins). The problem is caused by the plugin not reporting to Ardour the correct latency: the plugin was reporting a latency of 77 minutes (more or less) causing the problem. Inserting the correct latency manually corrected the issue. Unfortunately the latency is not saved in the project, so when I close Ardour and reopen it I have to set the latency again.

How do you set the latency of the effect? Do you use the Ardour provided override in the plugin’s UI? image

Yes, I use that button. I just tried using the Trileveler2 plugin from SonicAnomaly (JSFX) inside YSFX and it worked. Probably the issue of the latency not saved was from a previous version of Ardour, some other JSFX plugin or I probably got confused. I updated a few days ago from Ardour 7 to Ardour 8.
Thank you.