Ardour records choppy music.*Noob alert*

Hey first post in these forums. Hate to be a typical noobie, but after playing around with Jack/Ardour/Ubuntu for hours tonight, I am hoping somebody can give me some advice or point me towards a thread or website or something. I am an experienced Linux user, and I was hoping to try and record some music using ardour. I completed a fresh install of Ubuntu 9.10 32bit on my spare desktop system (an old p4 with 3gb of ram, a realtek ac97 onboard audio card, and some other old performance hardware). after the fresh install i installed ubuntustudio-audio and ubuntustudio-audio-plugins since i had heard it was the simplest way to get everything going.

ofcourse, when i tried to load jack with realtime, i encountered startup problems and whatnot. launching all my apps as root and/or using the rt kernel allowed me to enable realtime, but i encountered other problems.

mainly, i can get jack/ardour to connect to the audio interface i am using (a zoom S2t, i know its not great but i am just borrowing it until i can get funds for a decent firewire one) and no matter what sample size i used, or whether realtime was enabled or not, i choppy recording. there were other settings i did not play with, as they all seemed sane too me atleast. my audio interface was detected under alsa i believe.

is the problem i am having due to my ac97 audio card, or the audio interface, or the fact that its a usb device? perhaps its the driver i am using? (i started jack with alsa) i know the device works under windows, but the only prog i have to record with under windows is cubase le 4, which is craptastic.

any suggestions/chastising/direction would be much appreciated! i am willing to switch distros, or whatever. i am planning on starting fresh with ubuntu 9.10 again tomorrow. and is it necessary that i have the the realtime kernel? i have read that its not necessary.

like i say, any help would be much appreciated!

Yes, you need the RT kernel otherwise you’ll get latency problems which you’ll hear as choppiness but moreover you’ll see as xruns.

Your onboard audio could well be the problem. I get this when I try and run Ardour on my netbook. I can just about get it to work if I’m minimalist about the recording, shutting everything else down and using no plugins.

Having said that, the Zoom S2t may still be the problem - I wouldn’t know about that. Suggest checking by cutting it out of the loop - see if you get choppiness if you plug sthg directly into your line in/mic in on the mobo.

Hope this helps

@Grama; I have the same onboard soundcard and the same distro as you, but no problems. I even have the same amount of ram and a similar cpu (amd64 3200, but with the 32-bit ubuntu). Can you post the contents of your .jackdrc file here?

P.S. I often use the stock kernel instead of rt, and it works just fine here.

You shouldn’t need to run an rt kernel - I’ve never had to do that and I run many different linux distros on lots of different spec hardware. However, you normally need to add yourself to the audio group and make a few changes to /etc/security/limits.conf which will then enable you to start jack with the -R switch without having to run as root. This normally fixes choppy audio problems and I would regard it as essential before you look for other causes. That said, getting a PC to do audio properly is not always straight forward - regardless of operating system - but at least with linux there are more things you can change to try and fix the problem:

sudo usermod -a -G audio (your username)

edit /etc/security/limits.conf and add something like:

@audio - rtprio 95
@audio - memlock 512000
@audio - nice -19

you may need to change the memlock settings - some people run with memlock unlimited…

You will need to log out and back in again before the changes take effect. You should then be able to start jack in realtime mode e.g. jackd -R etc etc

When I was getting constant xruns on my old Athlon box I switched to the RT kernel and it seemed to solve my issues. IIRC, I couldn’t start jack in RT mode without it. Maybe I’m misunderstanding sthg. The advantage of RT and avoiding x-runs is described here: http://ardour.org/node/2465

On re-reading my previous post - perhaps I should have said ‘you may not need to run an rt kernel’ - to clarify, I’ve experimented with rt kernels to try and resolve issues with some audio hardware but in the end I didn’t find it essential to use the rt kernel to get stable audio performance. The changes to /etc/security/limits.conf and the -R switch for jack normally work well enough for me. However for some people it has obviously proved necessary - it does depend on the particular mix of hardware you have.

wow thanks for the fast response people, I really appreciate that! Sorry I was not able to answer back as quickly.

I thought I had added myself to the audio group, but alas, I had not. That let me run the realtime option (without the rt kernel), however i started to get a recidulous number of xruns. I could not get rid of the xruns, and my latency was high (64msec). i also changed my /etc/security/limits.conf to change the memlock from unlimited to 512000, maybe thats part of the issue. i also ran into problems in that ardour wasn’t behaving with the s2t, but that might just be a lack of understanding problem on my part. in qjackctl i could clearly see the S2t was working with the alsa driver, so i was a bit confused. The rt kernel did not help anything at all. at any rate, i am going to try putting the memlock back to unlimitted, and if that doesn’t work, i’ll give AV linux 3.0R1 a try. if it works well, i will make sure i donate.

considering how old the system i am trying to use and the fact i am using a usb audio interface, i am not holding my breath out on reducing my latencies, tho i am hoping to reduce xruns. i’ll keep you guys posted to see if i come up with a solution. again, thanks for all the help!

try setting the period/buffer option to 3 in qjackctl.
if you use a usb soundcard, that could help a lot with the xruns.

well avlinux worked, only had a marginal number of xruns over my recording session of several hours tonight! thanks for all the help, i am not sure what the cause of ubuntu’s problem is… all i know is avlinux worked quite well! thanks again!