Ardour Rec problem (fast track pro usb)

hello everyone!
im new in the forums so i really apologize if this issue is already solved.

i was trying to configure my MI audio Fast Track Pro usb interface to work with ardour.
finally i manged to get input from the FT, although the recorded sample sounds pitched up, maybe its duration gets shortened. Also, there is some strange tremolo effect.

i exported it to wav too, just in case it is a playback problem, but no.

there is a small mess in my head about jack control and ardour, so i wonder if i did something wrong there.
in jack configuration i used hw1,1 as input device, rest set to default.
in ardour configuration (during opening a new session) i used record and playback with 2 devices, set the input to usb #1 and the output to my motherboard card

im using Kubuntu 9.10

any help or hint will be greatly appreciated!

Here’s a little guide I did for this usb interface. PLEASE skip all the kernel patching steps (unless you want to really screw up all your system). Just look at the image in the bottom, the qjackctl settings and some of the final steps, for example if you have a RT kernel just do the rtirq steps if you feel like it, and also make sure your


has this at the bottom:

@audio - rtprio 99
@audio - nice -19
@audio - memlock unlimited

The guide is:

thanks for the quick reply!

unfortunately, i din’t manage to find a solution to my problem

i made a quick video just to help the diagnosis :slight_smile:

What sample rate are you using? After re-reading your original post it seems to me as if you are using two different audio interfaces for playback and capture (record)? This seems very strange. You need to use the same audio interface for both recording and playing back - or if you switch to a different audio interface just for playback you need to make sure it is running at the same sample rate as the interface you used for recording.

tried with 22050, 44100, 48k
each time i was setting jack to one, and then i was setting ardour (during open new session configuration) to the same as jack

each time, no matter which sample rate had i chosen, ardour seemed to work @48k, since on top right corner the indication was 48k, so i had to set jack to 48k too, to make the video

i thought it might be a playback problem, thats why i also tried to export to .wav file, which had no difference than the playback directly from ardour

but ill definitely try to use 1 interface for both in/out, the only reason i chose the motherboard for playback was that i have to dig a lot into cables behind my pc :slight_smile:

JACK is an audio server - when you start jack it connects to your sound card, and then once it is running, other JACK compatible applications such as Ardour then connect to JACK.

JACK is responsible for taking audio data from your sound card, passing it to the various ‘client’ applications such as Ardour and then finally passing audio data back out of the sound card.
This mechanism is synchronised to the rate at which audio can be handled by the audio interface, which is related to the sample rate and the buffer size. So you need the input and output halves of the soundcard to be running from the same timebase e.g. sample rate.
JACK client applications such as Ardour determine the sample rate they should run at from JACK.

It seems as though you have JACK (and therefore Ardour) running at 48K because this is the rate your onboard sound device is running at, yet you have somehow recorded the audio through another interface that is most likely running at a different rate - this is, I suspect, the cause of the problem.

first of all thanks for the great help!
you clarified a lot in my head. I tried to use only 1 device for record&playback so im sure i have the same sample rate for both functions.

i manged to run ardour @41k then i recorded, exporeted it to .wav and listened to it. The recording was flawless.

the only problem i get now is that i cant hear anything during playback in ardour.
-I set the Fast Track as “preferred” device for capture and playback in system settings->multimedia.
-I also set up jack and new session options like this (screenshot links)
I’m getting this error you can see in screenshot

Explore Iraklis Zs
Explore Iraklis Zs
Explore Iraklis Zs
Explore Iraklis Zs
Explore Iraklis Zs

thanks! :slight_smile:

Fire up qjackctl and copy the settings like I posted in my blog:

Except for:

Input device, select the one that says USB Audio #1
Output device, select the one that says USB Audio

But for the rest of the settings copy the rest

Start jack from qjackctl, then fire up Ardour and let us know how you do.


Oh, and you might have to play with the A/B button and the Level, Mix and Output dials on your Fast Track Pro, depending how you are monitoring, if from behind with speakers or front with headphones.

Thanks a lot for the great help!
i finally got it working. The only problem i had was that your frames/period was too low for my system, but i changed it to default value (1024) and its working perfectly, with 40 ms lag tho, but i couldnt expect anything better with my pc i guess

i cannot find any gathered piece of information about what all these settings are for in detail, so i would appreciate any good link :slight_smile:

thanks again! xD