ardour problem with qjackctl

I’m new to ubuntu studio. tried Ardour 3 with m-audio fastrack soundcard. It worked at first but now, every time I load Ardour, I get the following message:
[INFO]: LV2: Discovering 266 plugins
[INFO]: Loading menus from /etc/ardour3/ardour.menus
[INFO]: Loaded mixer bindings from /etc/ardour3/mixer.bindings
[ERROR]: JACK: jack_port_set_name: deprecated
[ERROR]: JACK: jack_port_set_name: deprecated
[INFO]: Loading bindings from /etc/ardour3/mnemonic-us.bindings
OSC @ osc.udp://kevin-G5460uk:3819/
[INFO]: Loading 87 MIDI patches from /home/kevin/.config/ardour3/patchfiles:/usr/share/ardour3/patchfiles
[INFO]: Loading history from /media/kevin/SAMSUNG/test1/test1.history

Could anybody help? I would be very grateful

There are no actual errors there. Solving problems with running Ardour and JACK, especially on Ubuntu (even Ubuntu Studio) is incredibly ineffecient to do on a web forum. I suggest you get on IRC (read and hopefully someone can help you there. Ubuntu continues to get a number of things wrong that make it a very annoying platform for people new to Ardour (and JACK).

There is a similar issue with hydrogen -

The latest version of jack (1.9.11) has deprecated jack_port_set_name - looks like the solution is to upgrade ardour or downgrade jack.

Your problem, whatever it is, has nothing to do with any of those error mesages.