Ardour on Ubuntu 14.04

On Ubuntu 14.04 (x86_64) I tried using synaptic to install Ardour. I found I was missing .

I then tried to compile from source. For some reason
I could not find jack listed when I tried:
pkg-config --list-all | grep jack
I know jack has moved to a
more recent version but it looked like V1 was still available
and installed.

Any ideas?


I’d suggest forgetting about Ubuntu’s Ardour packages and either adding the KXStudio repositories and then installing both Ardour and JACK from the KX repos, or get the official Ardour build from here at 3.5.308 is quite out of date and has some known bugs in it. Ubuntu’s main repository Ardour packages are quite often borked unfortunately…

KXStudio repos:
Ardour Official Binary:

This was the complaint from instalilng with Synaptic:
ardour-3.5.308~dfsg-1: error while loading shared libraries: cannot open shared object file: No such file or directory
However, I found the symbolic link and file in /usr/lib/ardour3/ and it all looked OK including permissions. I tried to recreate the symbolic link with no
change in the complaint.

I had no issues installing Ardour 3 from the Ubuntu Software Center on a fresh install of Ubuntu 14.04 but like GMaq said, you’re better off installing Ardour from or by using the KXStudio repos. One thing I do notice when using Ardour 3.5.308 from the Ubuntu repo is that it has Unity Global Menubar support. As I am a huge fan of OS X and Unity, this option is definitely a plus. If anyone here knows how to get Unity Global Menubar support with Ardour 3.5.380 from please inform me.

@rockeral: we’d have to add explicit support for that, which we don’t plan to do because …

@paul: Ah, that is a shame, I hope Unity design team doesn’t remove the global menu bar option all together in the next version of Unity as this would make it a little less compelling at least in my opinion. Well none-the-less thanks to you and your team for the enormous work on Ardour and I look forward to the next release.

OK I have the 4 tar file…how do I install it…is this done in terminal?

If you have a "tar" file, you've download source code, which needs to be compiled. You almost certainly don't want to do that.

When you download a prebuilt binary, you will be point at which explains the install process.


There is not much choices here. As the « Ready To Run» prebuilt binary turns «Silence after about 10 minutes» and there is no other way than paypal…

Can’t wait for the Ardour 5 :slight_smile:


Other choices:

  • get it from a linux repository
  • get it from a friend
  • get via a torrent, preferably with an ardour.keygen (seriously, don't do this, it is almost certainly a virus)
  • find somebody else to build it for you

Enough choices?

Get your tar file and open it.
Go inside then :

./waf configure --with-backend=alsa,jack --no-jack-metadata --prefix=/6_years/people/asking/paypal/alternative/so_hard_to_do

you can have the configuration options with :

./waf configure --help |less

Adapt accordingly to your needs/installation.

If the configuration fails with some packages missing, add them : (here on Gnu/Debian Wheezy, you have to adapt accordingly to you package distro and the package you already have or not)

aptitude -R install libraptor2-dev libsndfile1-dev libgnomecanvas2-dev libsigc+±2.0-dev libcairo2-dev liblrdf0-dev libfreetype6-dev libfftw3-dev libglibmm-2.4-dev libcairomm-1.0-dev libpangomm-1.4-dev libatkmm-1.6-dev libart2.0-cil-dev libgnomecanvasmm-2.6-dev liblo-dev librasqal3-dev libogg-dev libflac-dev libvorbis-dev libsamplerate0-dev libaudio-dev liblv2dynparam1-dev libserd-dev libsord-dev libsratom-dev liblilv-dev libsuil-dev librubberband-dev vamp-plugin-sdk libaubio-dev libjack-dev liblilv-dev

Once the configuration is done without errors :

./waf build -jX

X=thread your cpu can handle. example : ./waf build -j12

Wait a little, it’s fast on recent CPU with cores.

Then go to the directory you’ve declared in the configure --prefix=
For example :
cd 6_years/people/asking/paypal/alternative/so_hard_to_do

You’ll find directories :
bin etc lib share

cd bin

Work perfectly on a Gnu/Debian Wheezy.


ps: nop, miss one choice : Remove the «silent» limitation , and install a credit card payment. «Subscribers 692» you should have 100 time more if no more !


As of the 1st January this year, the EU rules on the sale of digital products (including and most importantly, downloads) changed to make it exponentially more difficult / time consuming to comply with the necessary bureaucracy. Simply put, if you sell software to a country in the EU, you used to be able to charge VAT at the rate where the seller was based - which for small businesses with low turnover in e.g. the UK might have meant not having to charge / register at all.
The new rules mandate that the rate be charged as applicable in the country where the buyer is based. For many EU countries there is no zero rate band, which means anyone selling software would have to register, and collect and remit the taxes seperately and at the appropriate rate, for each member state in which they sell.
I imagine that if Paul were to independenly offer builds of ardour for sale, at a fixed price, e.g. by using a credit card processor, via a merchant account, not only would he incur the expense of being / having a merchant account (and the necessary compliance red tape) but, as the vendor of a digital product, also have to charge / submit the relevant VAT (as above). This would immediately add approx 25% to the cost of the product ( or mean a 25% hit in any profit) in addition to any fees for payment processing.
I mention this to highlight just some of the complexities of trying to solve this problem. In short, if you want the software built for you, use paypal and stop complaining (its not that hard, you just need a bank account) or accept that the alternative would be much more expensive - with very little of that cost being passed back to the developers (once the parasites have had their share) - and most likely would mean the developer(s) spending all their time filing VAT returns and not developing the software.

On Sun, 2015-04-26 12:09 linuxdsp says :
use paypal and stop complaining

Ja meine Brigadeführer !!

@pingouin Regarding your post on Sun, 2015-04-26 18:16 :
In my opinion, if you are not a developer, giving instructions on how to freeload is actually the lowest level you can get to in here. Yes, the Instructions are freely acessible online, but these are not actively promoted by any of the developers for good reason. Learn to read between the lines and understand the project.
By the way, I hear letters and stamps still exist. Maybe put in a nice postcard with the donation to keep it in shape.

On Sun, 2015-04-26 19:07 t0bY says :
In my opinion[…]

I’m having trouble installing 4.0.0 on Ubuntu 14.04 (and OpenSuse, but this post is focused on Ubuntu 14.04)

bri@bri-PowerEdge-700:~$ /bin/sh ./
/bin/sh: 0: Can’t open ./

is there a work around?

Pingouin: your conduct on this thread towards other people makes me seriously contemplate deleting your user account.

I have no problem with you telling people how to build Ardour, or at least I wouldn’t if the instructions were better written and more accurate and more useful to people on non-debian platforms. We have platform neutral and more accurate instructions at where they have lived for a couple of years or more.

But your approach toward linuxdsp and t0bY are unacceptable. I’d appreciate if you would stop.

@paul: “Gently spoken, but carrying a big stick”. Good work.

The guys on #ardour at were really helpful. Many thanks to them. They pointed out that once cd’d into the directory (home in my case, no cd needed) simply inputting “/bin/sh ./” into the terminal eliminated the installation opening conflicts for me i was having. Ardour 4.0 then installed seamlessly and quite smoothly and worked great. Thanks to Paul Davis and his team for a nice release.