Ardour on Steam Deck - working!

Hey there,
Since I saw that a question was asked here regarding the Steam Deck, I would like to share my experience with you.
Ardour runs on the Steam Deck (you have to experiment a bit with the scaling - between unreadable and a window larger than the display), I tested it briefly with the flatpak version of Ardour and my Steinberg UR22. But so far I have not been able to change the directory of Ardour to record directly to a folder on a microSD card. Maybe someone knows how to do that?

hello mesul,

to change the project directory visit the help page:
The description is clear, simple and success-oriented.

Hey Thomas, thanks for trying to help. The problem with the location is a bit more complicated. In the Session Management menu you can’t find/access the /run/media/mmcblk0p1 partition of the microSD card. If I copypaste the path to my desired folder on that partition Ardour displays an error “No such file or directory”.

Hello Mesul,

what file system was the microSD card formatted with?

It may be helpful to format the microSD card with a file system that any program or operating system can access. I myself work with Linux and Windows. I have had very good experiences with the FAT32 file system. This is recognized by every program as long as the necessary drivers are installed. The disadvantage: the file size is limited to a maximum of 4 GB. A FAT32 partition can be a maximum of 32 GB. Give it a try.

Ardour sessions are case sensitive. A FAT32 fs does not usually work and often breaks sessions. Prefer NTFS on windows, extfs on Linux,

I suspect that is the problem. First keep in mind that the flatpak is created by a 3rd party. Ardour developers are not involved and cannot provide support.

That being said, flatpak’ed application are sandboxed, and require special permissions to access files on the system outside the sandbox. Have you set those?

Ardour records directly into the session-folder, you can select that when creating the session.

1 Like

Nice that you are here. . . Robin.

Ah, sure, I forgot about the sandbox. On Steam Deck it’s possible to install Ardour not using flatpak, but after a systemupdate things can be broken/removed. I will check permissions. Thanks a lot!

It looks like you’re out of luck:


I tried to allow Ardour to access my desired folder on the microSD via flatseal (manages flatpak app permissions). …it worked. Created a new session, recorded a short audio, saved - directly into the folder. Great! Thx again for the hint considering permissions, Robin! :smiley:

Next test: recording audio from X32 in the practice room in a few days.

1 Like

Wouldn’t it be great, if the devs support an official flatpak release with set permissions in advance. :slight_smile:

The binary from Download Ardour | Ardour Community works exactly that way. It installs in a dedicated folder, comes will all dependencies, and is not sandboxed.


Just use a desktop computer

…for anyone who is interested: The recording test with the X32 has been performed successfully. I was able to record my drum tracks directly into the project folder on the microSD card and play back the material via the X32’s AUX channels. Nice!

Changing the pipewire sample rate works - as expected - by creating and editing a pipewire.conf in the home directory, without needing to change the read-only mode of the root file system.

Have a nice weekend, everyone!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.