Ardour on netbook?

This isn’t technically a Linux issue, but I had it happen on my Linux computer so…

On a whim I installed A3 on my netbook so that I could do some quick editing and recording, only to find out that “This screen is not tall enough to show the mixer window.”

This probably isn’t that high of a priority but being able to make the mixer show up with a scroll bar on the side, or being able to scale it down to fit on smaller screens would be nice.

nixcamic: yes. i’ve tried running a3 on my wife’s betbook and this was the reason i added that message: with the editor mixer visible, the editor window becomes unusable (or at least, nightmarishly frustrating). i didn’t have time to do the change that would pack it into a scrolling window, so i just made it not show up. at some point, i’ll make more changes to work on these vertically undersized screens …

Paul, I’d really appreciate it if you’d just let us use the mixer window on a netbook anyway, broken or not. Disabling the mixer completely makes ardour even more unusable, not less!

1 Like

(at the moment I have to rotate my netbook’s screen in order to use the mixer, which is an unbelievable PITA, but I need a capable LV2 host, so there you go)

@markhadman: i’m not going to do that. I was absolutely horrified by the completely unusable state that it put Ardour in to have the mixer strip visible in a “short” window. i am not goign to revert to a solution that will immediately have anyone trying ardour on a netbook concluding that it is a heap of crap. The right solution, as was suggested, is to put the editor mixer strip in a scrolled window.

Also note that it is totally dependent on the screen not the netbook - I hooked ours up to our TV screen and things were peachy keen!

Sorry Paul, you appear to (oddly) misunderstand - It’s not just the /editor mixer/ that’s disabled, it’s the entire /mixer/ window. In other words, there is currently no mixer AT ALL on my netbook unless I rotate the screen or hook up an external monitor.

@markhadman: both options were awful. the one i picked at least got you to request a change rather than just say “oh man,this program is totally not designed with netbooks in mind”. i will make some kind of revision here for 3.2

@markhadman: Are you using the monitor section? Either try with disabling or undocking it. Also did you try with getting rid of some buttons via Edit->Preferences->GUI->Mixer Strip?

the_CLA: none of those things will help. i disabled the mixer strip & mixer window because they were unusable in a “short” screen. unusable as in “what the hell is the developer of this app thinking?”

paul: That’s interesting. I don’t have a Netbook, but with undocking the monitor section and disabling the buttons I can scale down the mixer window to a height of 534 px - and that is including the window decorations.

Paul, I really like using Ardour 3.2 on my main computer at home but I use my 'Netbook when travelling. To not have the mixer shown because of the “short” screen is extremely frustrating. I don’t mind “scrolling”. Is there a plan to rectify this soon?.. like yesterday? :slight_smile:

Hi just downloaded A3. I had been working on A2 to do a little bit of experimenting with mastering, and decided it would be good to upgrade. I too work on a netbook. The mixer being too big was a bit annoying, but I didn’t think it was too bad a black eye for you (e.g. the developer). Right now, I cannot use this updated version since I want to work with effects.

As a suggestion, would it be possible to do follow a middle way and display the warning the first time it occurs upon opening the application, but then letting the mixer to be usable?

Hi quick work around for people on linux while this issue is in the works. Before running ardour, in a terminal type:

xrandr --output LVDS1 --mode 1024x600 --panning 1024x768 --scale 1.0x1.28

Things will looked a bit squished. To get out of this when you are done, type:

xrandr --output LVDS1 --mode 1024x600 --panning 1024x600 --scale 1.0x1.0

Thanks to the guy on:

in sorting out the issue, forgot to say thank for creating an excellent piece of software.

@libreaudio, thanks so much for posting that. I’ll be trying it very soon.