Ardour on Linux


Maybe I am exceptionally unlucky. Every now and then I decide to finally move to linux (from OS X) only to realise that I cannot get anything to work and give up on the idea! I really really want to make the transition as most software I use is open source and I have heard reports that Ardour’s GUI is more responsive on linux than on mac. So it all sounds promising, but here is my experience so far.

I installed 64studio to find out that the version of ardour pre-compiled for Debian has a serious bug (crashes when using tab-to-transient). I then moved to fedora 11 and planet ccrma and found another weird bug with ardour which skews the GUI after resizing GUI elements (e.g. track heights or the region section). However I remember that ardour was working fine on fedora 12, however my machine would randomly freeze on F12 on a regular basis so I regressed to F11.

So Ardour is not working out of the box (at least for me) and to get the latest version I need to build from source. Now this is not good news for a linux newbie and is enough in itself to turn someone off linux for pro audio work. Surely there should be an easier way to get the latest release pre compiled or else how could a complete newbie be expected to ever migrate to linux (and I am used to coding and I have built applications on OSX before so I’m not a computer dummy)? I mean why would I move to linux and use a really old and bugy version of Ardour when I can stay on OSX and use the latest and most stable version without having ot build from source?

In the meantime my question is: how do I build Ardour on Fedora? How do I make sure which dependencies I have and which I need to install and how do I install these? I have seen this but I cannot follow it as I don’t know where to get all the tools and libraries for fedora and to check if I already have them.

I would suggest that the Ardour project should recommend one regularly tested linux distro and always provide the latest package for that one distro: maybe even a .deb file or something similar.



I’ve been swamped with work and other life stuff so I have been away from linux audio discussions for a few months. I saw this thread and was about to suggest AV linux when I saw someone else already did. I have enjoyed AV immensely, it has been the best music linux for me. I never really got ubuntu studio working correctly. I am very very interested in your ardour machine though efflux, that’s pretty amazing. I was just saying the other day someone should create a totally stripped down, just run a DAW machine, which would be similar to what radar is then. I’m not linux savvy enough yet to achieve that, or maybe I am, what’s involved? And yes, P4 and linux are still a great match, I have a p4 my neighbor was throwing away that is about to get mythbuntu loaded on it.

What about Ubuntu 10.04 + this ppa to keep everything up to date (

Also, you’ll find plenty of documentation on how to properly set up ubuntu on a mac, and ubuntu for real time audio.

One thing ubuntu is lacking is a proper rt-pae kernel, but dickmacinnis made a very good one on its repository:

No need to build ardour from source if you use this stuff.

To be honest, I think Fedora is far too unstable and experimental for anything, and 64studio is way too old. To me, Ubuntu LTS is the way to go, this is just a hint I don’t want to start a flame on distros.

Thanks vervelover for your suggestions. Doesn’t Ubuntu studio come with a rt kernel?

yes but it can’t handle more than 4GB of ram and it’s a bit old (2.6.31), anyway it should also work. However, ubuntu also requires a bit of tweaking to make Ardour and rt jack audio work, but the good thing about ubuntu is that you can easily find a lot of documentation everywhere, you feel that you are never let alone. And, once you set it up, it’s rock stable.

OK, great. I’m downloading Ubuntu now and will install it later today and then try to get the rt kernel to work.

Thanks again.



Ubuntu 10.04 does seem to have a pre-built version of ardour / jack that gets as close to working ‘straight out of the box’ as I’ve yet seen, but on just about every install of Ubuntu 10.04 I’ve done (and this is on three different machines currently that I use for testing my plugins) I’ve had to make the following ‘tweaks’ after the install:

  1. While installing ardour / jack from the ubuntu repositories, it throws a dialogue asking if realtime permissions should be set for JACK - this is necessary or (because jack now defaults to realtime mode) jack won’t start at all, and you may be met with a message from ardour that doesn’t completely give away what is happening. However…

  2. Despite the installer making the required changes to what used to be /etc/security/limits.conf, (but is now somewhere else that I can’t remember), your username will not be added to the audio group, so I have found I have to add mine manually after the install of ardour by opening a terminal and typing:

sudo usermod -a -G audio username

where username is the user name you login with.

After this it is necessary to log out and back in again, but I normally do a complete restart just to be sure (…this morning when I booted my netbook running ubuntu netbook remix, it required three restarts to get all the new ubuntu updates that were waiting to complete before I could do anything with it… Ubuntu gets more like windows every day :frowning: but I digress…)

Once these changes have been made, ardour / jack will start up, but I’ve found that pulseaudio normally gets in the way at some point (two machines wouldn’t play audio at all - from anything) and the netbook gives 50% DSP usage from ardour… until I removed pulse audio, whereupon it dropped back to a more respectable 2% and everything (including all the normal audio stuff - worked just like I expected it to)

Removing pulse audio can be done by opening a terminal and typing:

sudo apt-get purge pulseaudio

This may be a drastic step, but I didn’t have the time or patience to find out which bit of the pulse config was causing this behaviour…

None of this is meant as criticism - ardour / jack is superb (and compiling it from source is normally trouble free if you follow the instructions on this site), and ubuntu is one of the most trouble free ‘general purpose’ distros I’ve tried, but setting up a system for pro-audio is almost certain to require some tweaking. I hope this is useful…

@ linuxdsp

I don’t think removing pulseaudio is a good idea on a system that is not a netbook (and a netbook is certanly not the best for pro audio work), on a good computer I think it’s less trouble to keep pulseaudio than to remove it, cause the performance improvement is minimal (at least on my laptop). Well, that is, only if pulseaudio is not screwing things up anyway, which definetely is a possibility. Maybe the best is to try it out and see before doing anything…

Also, a good thing to do is to add the cpu clock applet on the panel and remember to set it to performance mode, because the default “ondemand” setting is a pain for pro audio work.

@vervelover: I would generally agree, I should just point out that I run ardour / jack on a variety of different machines of different specifications with different distributions in order to test the plugins - obviously I normally use a much higher specification machine for audio - but in almost all cases I’ve had some trouble that can be traced to puseaudio. Although I appreciate what pulse was designed to achieve and why it is useful, I just don’t find it plays well with JACK at the moment (for me anyway). I used the example of my netbook config problems to illustrate some of the issues I’ve encountered. (And its also quite surprising what can be done with audio on these small computers too…)

The recommended way of getting rid of pulseaudio is found in (Disabling pulseaudio).
jackd post installation script writes rtprio and memlock security limits to /etc/security/limits.d/audio.conf for the users who belong to the audio group. Then, qjackctl messages will tell you that memlock unlimited is not a good idea and you should put a value in kB (75% of your RAM, I think).
Building ardour in ubuntu is a breeze with “apt-get build-dep”

EDIT: Regarding PPA’s, when I tested lucid some weeks ago, I saw that falk-t-j/lucid makes you install jack2 and it is not as stable and well packaged as philip5/extra, imo.

Cheers! Pablo

Amazing. Thanks all for your replies. It seems like ubuntu is the way to go. Unfortunately my download was corrupt and the installation stopped halfway through. So going to get some more disks and re-download it. I will report on the process :slight_smile:

@ Pablo: Do you mean to build Ardour all I have to do is type “apt-get build-dep ardour”? cheers.



@Peiman: No, but it will save you time and hassle
“sudo apt-get build-dep ardour” will install almost all if not all the building tools and development libraries that ardour2 needs to be built, at one time. I am not sure if libtool and autotools-dev are installed by this method but you will need them aswell.

To actually build ardour, follow instructions in this site:

Thanks Pablo,

So I just installed ubuntu. And installed the dream-repository. However after installing jack and running the command that linuxdsp suggested (sudo usermod -a -G audio myusername) I still can’t get jack to start (from Jack Control) as Jack crashes (“Could not connect to Jack server as client…”). Will play around a little bit and see what happens!



You need to restart the computer after adding your user to the audio group. Try not to tweak too much in the jack setup, especially when you don’t know what you are doing. It is easier than it seems at first sight.

Thanks Pablo,

Yes I did restart but no help. And I found another problem: the screen goes blank after a few mins of not using the mouse and keyboard. I have set the system to never go to sleep but it still happens. I guess that’s a post for the ubuntu forum. Well I’m reinstalling ubuntu and will have a fresh start!!

Thanks again,


Hello again,

@ vervelover: just to be sure. After installing how do I install the rt kernel? OR do I just restart and that’s it?



Yes, you need to read ubuntu’s forums and documentation.

OK it was a problem with the power management. Solved

I had to also make some changes to /etc/security/limits.conf and jack is running. I had to add these lines to the file:

@audio - rtprio 100
@audio - nice -10

No idea what they are but it did the job!

Wow ardour feels so much more solid here, and it’s working too :slight_smile:

Thanks everyone for your helps, much appreciated.



@ peiman

to install the kernel, go to system–>administration–>synaptic package manager, hit the reload button, then search for linux-rt, and install the package called linux-image- (this is not the exact name cause I can’t remember it but it’s close), then reboot, keep the shift key pressed, and select the kernel from the menu that pops up. This way you will boot the rt kernel.

@ vervelover: amazing. It works!! I am really impressed, considering that the computer I’m using is 10 years old!

So that’s decided, I’m gonna get a new desktop and install Ubuntu on it. No more OSX!!!

Thanks for the help.