Ardour on Drupal

I have a suggestion for WHO ever is managing this drupal website.

/admin/settings -> Cache support: disabled!

It appears that it is set and it can cause caching issues (can be solved with shift or control reload /depending on browser).

I had identical symptoms on my personal website (an underpower machine and thought that enabling caching would help). It ended up slowing down (it seemed to ME) as sometimes the cached pages in the MySQL server appeared to not update when it was an HTTP header issue caching has always been a problem between IE and non-IE browsers / fix for on, it is broken for the other – (using FireFox on Linux).

The caching option tried to use some slight of hand to determine if content hasn’t changed and if not, send a copy of a page to you (which may or may NOT be personalized depending on how you setup the drupal system per user account). There are several problems with the logic (from the web-server and from the client/browser).

Symptom: Log on, and then it appears you are still NOT logged on (shift-reload solves) – problem: caching issues.

I disabled the cache support and it solved my issue. It does increase the load somewhat (slightly) but it is less load that having to re-load the page twice – in the LONG run, it is a toss up! The server doesn’t have to create a server-side caching process (takes up MySQL space as well as additional logic to update such pages).

Now for folks that NEVER log into the system, the cache option will not make much difference.

Also Drupal server side-caching should only be enabled on a web server that is slow or unresponsive. Otherwise, disable it.

Just my thoughts. And I think it would be rude for my to post (plug) my website – so I will skip that! Even tho I have an area reserved for my experiences with things “Ardour” related.


I second this. Logging in is absolute hell, especially when I use LINKS as my web browser.

Login in IS hell…

Marc-Olivier Barre
Kinoko en Orbite