ardour not starting, audio card working

I can’t manage to start ardour, I always get a message “could not connect to the audio/MIDI engine”
I have a m-audio fast track ultra installed in LinuxMint 17.1 on a Acer travelmate B115.

My audio card works well with alsamixer, JACK and in Pure Data. I tried several settings (buffer size, sample rate, ALSA or jack etc.) in the startup menu of Ardour but without success. It seems as if Ardour cannot find the drivers of my audio card, when I try to calibrate the card in Ardour I get the message:
Failed to connect to audio engine. Latency calibration requires a working audio interface.
I tried these different settings in Ardour 3.6 and again in Ardour 4.2, same results.
I also tried changing the frequency scaling of the CPU but this procedure is not available on my computer.

system information:
Linux 3.16.0-38-generic #52~14.04.1-Ubuntu SMP Fri May 8 09:43:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Calibration is a special step that requires a physical loopback cable. It is not necessary for use of Ardour (it simply provides more accurate latency compensation). So please ignore this and focus on issues with the audio interface. You said it works with JACK? Can you just use Ardour with JACK? If not, what are the errors? Please focus on Ardour 4.2 and not earlier versions.

I just can’t start Ardour and get stuck in the opening screen to create a new session (‘session setup’ followed by ‘audio/MIDI setup’ screen). One of the things I tried was to start jack (and switch audio on) before launching Ardour, but without success (this message pops up again “could not connect to the audio/MIDI engine”).

1 Like

Have you tried disabling Pulseaudio? Ubuntu in my opinion is heavily relying on Pulseaudio and it causes a lot of error messages, Ardour definitely doesn’t like Pulseaudio. Google “pasuspender jackd”.
Also, I would consider installing a realtime (rt-linux) kernel and making sure your kernel realtime priorities are ok. A generic kernel is not usually set for realtime operations.
I’m using Debian, to which I installed an official rt-kernel through Synaptic, which also took care of realtime priorities when installing jackd. Works fine, even on an old, 32-bit Intel Core-Duo - laptop with Lexicon Omega interface - which BTW has a separate power source and so doesn’t use the USB connector for power transfer. Maybe Fast Track is hogging the USB connection for its power…?

Did you choose JACK as the audio backend? What dist are you on? On Fedora 22 ardour backends are in separate packages and you have to install the ones that you want to use. Check what user jack is started as, it should use a normal user and this user has to have rt sched privileges and memory lock privileges, you have to check /etc/security/limits.conf and/or /etc/security/limits.d/*.conf. On Fedora you have to add your user to group jackuser.

I tried a live version of Ubuntu Studio 15.04 Vivid Vervet on a usb stick (with realtime Kernel version 3.19) and then Ardour (version 3) worked (with Jack as backend). So I guess I’ll install this kernel version on my laptop… I’ll read a good explanation first

I previously tried disabling pulseaudio, I checked the group and privileges, but all this without result, the same message kept popping up. By the way this maudio fast track ultra also has its own power source (not necessarily via usb).

I’ll keep you informed if the kernel update on my laptop finally worked.

Let me know your results. I just upgraded to 4.4 on both my Arch and Mint distros and neither will start a session. I’ve tried connecting to both ALSA and JACK. I get the loading session screen stating it is has loaded tracks and starting session then just stops and closes. This is happening with every existing session. I was working on two sessions last night without issue. I have not yet tried to start from terminal.

Moonbeahm79: http://ardour.org/debugging_ardour.html

Thank you very much Paul. I am now not sure what the issue is, because it doesn’t crash and starts right up in gdb so there is nothing to report as a bug. Is it possible that I may have to start Ardour from command line for some sessions and some not until this issue is fixed? Like the above user, I have tried multiple kernals as well ffor each distro. I’m baffled at this point.

Nevermind Paul, the entire system crashed and when I restarted and started Ardour via gdb, it got stuck. I submitted an issue in Mantis along with the log from gdb.

Hopefully you’ve read Robin’s comments on your bug (http://tracker.ardour.org/view.php?id=6644) which explain how this is a problem with plugins that you’re using and that it can’t be fixed by Ardour.

Long story short,
I had thesame proplem. Fast Track Ultra, Ardour 3 works in Ubuntu Studio. I am on arch (manjaro) so no more Ardour 3 and Ardour 4 displaying this exact error.
It happens that on the second configuration popup I had let “ALSA”. So I just setted it to Jackd (after having launched it before of course) and everything went well

Ardour 4.2