Ardour Maxed Out

Recently, I was mixing a session using Ardour 6 and had experienced something unusual a couple of times. Below are the descriptions of the issue.

This session is a live recording with a total of 60+ tracks and with all the busses, it totals, almost 90 tracks. After 15+ mins into the session, the busses would go into ‘clipping-mode’ and the busses’ meter would read between 16db ~ 37db. As this happened, the Master L+R would distort BIG TIME and then the Left channel would slowly fade away leaving the Right channel with the distortion.

Then the session will be not able to quit at all. It happened so many times and I always have to reach out to the Task Manager to quit Ardour, leaving the session unsaved.

And yes, the DSP showed 100% but the computer’s CPU appeared to be different. There is only a load of 60%~70% from Ardour in the Task Manager menu.

I really cannot mix the session at all.

Anyway, anybody experienced this before? And what can be done?

(All in all I have a rough count of almost 90+ plugins. My computer is a 8th Gen. i7-8750 with 32GB of RAM and Samsung 970 NVME storage. If this helps…)

That’s reasonable. Ardour should be able to handle much larger sessions even on 5-10 year old systems.

That is usual. Are there any plugins or effects? Perhaps a feedback loop that builds up.
What happens after15 mins that is not present earlier on the timeline?

One explanation might be reverb plugin that is fed silence for a long time, some can produce artifacts then. Check Menu > Window > Plugins DSP load.

Also what buffersize are you using? Menu > Window > Audio/MIDI Setup.

They’re two different things.

in short DSP load is

“The time it takes to process a part of audio incl playback” vs. “duration of the part of audio”.

Unless you do very heavy effects processing, this not CPU limited but more often constrained by the system (mainboard, I/O, bus power-saving) A lengthy, but good explanation: https://www.youtube.com/watch?v=GUsLLEkswzE

Anyway it sounds like perhaps some runaway plugin. Just playing 64 tracks should hardly introduce any load.

1 Like

Hi Robin,

Thank you so much for the prompt reply! I am very impressed!!!

Alright here’s to the answer for the questions you mentioned above : -

That is usual. Are there any plugins or effects? Perhaps a feedback loop
that builds up.
What happens after15 mins that is not present earlier on the timeline?

Details of the plugins inserted -

  1. Plugin Alliance - Focusrite Channel Strip x 52

  2. Waves API 550B x 16

  3. Waves Scheps 73 x 16

  4. Waves PSE x 24

  5. Waves API2500 x 8

  6. Waves IR1 Full x 2

  7. Acustica TanZL x 6

  8. Acustica CoffeePun x 2

  9. Analog Obsession RareSE x 2

  10. Fabfilter ProQ3 x 1

In fact, there should be quite a few more I wanted to insert but was wary
of the DSP overloading, thus, I back down to the above-mentioned numbers.

I have definitely checked for any feedback looped and there wasn’t any at
all.

Roughly around 15 mins the Busses start to ‘bleed’ going into 16db~37db on
the meter reading and distorts. Then the Master Left channel will slowly
fade off leaving just the distorted Right Channel.

One explanation might be reverb plugin that is fed silence for a long time,
some can produce artifacts then. Check Menu > Window > Plugins DSP load.

I would usually add reverb as I mix and so far, there is only 2 instances
of the Waves IR1 Full for the Vocals. So they are full on most of the time.

Also what buffersize are you using? Menu > Window > Audio/MIDI Setup.

Buffersize setting is at 2048 since I am mixing only.

Unless you do very heavy effects processing, this not CPU limited but more
often constrained by the system (mainboard, I/O, bus power-saving) A
lengthy, but good explanation: https://www.youtube.com/watch?v=GUsLLEkswzE

Anyway it sounds like perhaps some runaway plugin. Just playing 64 tracks
should hardly introduce any load.

My computer’s Windows 10 is ‘stripped-down’ to the bare minimum with a
dedicated partition to run Ardour only(and definitely less than 10%
Windows’ background applications)

Appreciate your help in this, Robin!!!

Thank you, again!!!
Best Regards,
Simon Su

+65 9645 1101
simonsubh@gmail.com

EDIT: Just added in blockquotes so I could follow your comments vs quotes from Robins’ post a bit easier – Seablade

The buffer sizes you use results in a time window. Ardour and all plugins must be able to do their processing within this time window. The DSP usage tells you how much of this time is used up and if it reaches 100% it means that Ardour and the plugins need a bigger time window to do all the processing than is available with the current buffer sizes. If you reach 100% DSP usage then bad things happen to audio because there just isn’t enough time to process all of it. So it does not help if Task Manager says you have some unused processing cycles left, since it is not about available processor power but about your computer being able to do all audio processing within a given time window.

So the first thing to try is doubling or tripling your buffer sizes and see if the problem persists. If this does not help then lower the plugin count by creating effect busses instead of using plugins on individual audio tracks.

Edit: If you really have 129 plugins running then there’s your problem right there. On big sessions you need to find a way to be economical with plugins and save resources where ever you can.

Thank you for the reply, Mikael.

I have reduced the number of plugins and it seem to work just slightly better. In the meantime, it should work for me. I came from working in Samplitude X and had never encounter issues like this for years now.

Anyway, I know what to do to avoid this in the future.

Thank you!!!

Samplitude’s audio engine offers lots of different options ranging from the full hybrid low latency mode to economy. I used to flip between the various modes depending on the task (recording vs mixing/mastering) and size of project. It’s one of Samplitude/Sequoia’s hidden gems but finding the optimum mode coupled with its myriad buffer/performance options/checkboxes was not always obvious! Depending on the mode you used, it might explain why you could get away with 129 plugins :wink:

Alright! The same problem came back and with a vengeance. I have lesser plugins this time and the DSP load dropped between 69%~75%. I could mix for a while and then my main buss start to have artifacts, like clipping then the meter slowly went to to +40. This happened even after I stopped the playback. This is already the fifth time it happened.

(Anyway, I still have my SamX5 so I could at least hand up my work on time.)

I am just curious what exactly happened here.

What plugins are you running(You mentioned lesser plugins)? Especially what plugins are running on that track in particular you have pictured? Does it happen still even if the project is opened in safe mode (All plugins disabled)?

  Seablade

If I remember correctly DSP usage should be kept under 50% to be on the safe side (somebody correct this if it’s wrong). This is because other processes starting from time to time on your machine might eat up processor cycles leaving less for Ardour.

Did you try to increase buffer size ? You could also try to assign all available processors to Ardour.

Ardour_All_Available_Processors

Might be also an issue with a plugin. When this happens again press alt + b to open Meter bridge, then drag its window open to see if a track volume is maxing out and check the plugins on that track. By the way, why are you having 2 master tracks ?

On a decent system up to 80% should be easily doable. If the system is really tweaked for realtime anything under 100% is theoretically possible. My memory is this was Windows so I would probably aim for the under 80%.

    Seablade

Thank you for the suggestions!!!

I have already tried whatever was suggested except the ‘Safe Mode’.

Anyway, the session would always work fine until 15~20 mins later, in which, I would start to hear minute ‘tick’ artifacts, and this ‘tick’ would soar and gradually distrotions would kick in. The metering would gradually move into the positive range and usually, the left channel would be faded down leaving only the Right channel.

I took out the Acustica Coffee Pun and Tan plugins which I thought might be the culprit. Then most of the channels/busses are only processed with P.A Focusrite Channel Strip and Waves PSE only. The Busses would get the Waves API2500, Scheps73, F6 and some Free plugins which I have been using for some time now.

Buffer size = 4096 via the computer’s MME driver.

Plugin = 100

Channel = 56

Busses = 24

Mikael, that Buss is my -1 Buss before hitting the Master.

(Anyway, it seems like on one here experience this issue other than me)

Thank you for the advice!!!

I’ve noticed on my system (I’m on Linux) since moving to iterations of Ardour6 I’ve had more “feedback-like” issues popping up. I had huge trouble trying to get a sidechain compression setup working on a bus (Ardour kept triggering the “feedback” alert) and although I used to do this all the time in A5 I figured I must have been doing something wrong…

Then I had some issues with “feedback-like” situations that sound similar to the OPs, where a bus would slam up to 0dbFS on the meters (as would the master bus and my interface’s output meters), and if I remember correclty, usually resulted in super-crunchy noise that hit at full-scale, and tapered off to silence - but with meters still pegged, including my interface output meter which I believe is analog - my guess is that the signal was ultrasonic or DC.

There’s a thread about Dragonfly reverb doing this, which might explain what was going on in my particular case, but I haven’t done much audio since then (but will be over the coming weeks).

This is of course, of no use whatsoever to the OP, but thought I’d bring it up in case there is some commonality between changes to Ardour6 (I’m thinking of the bus-related latency changes) and these odd feedback-like issues cropping up. I’ll try and do some proper digging in the next week or so to provide some actually actionable information, but thought I’d throw this in here in the meantime in case it triggered an idea for anyone.

The two are not related. The situation with feedback is unchanged. The “feedback indicator” lights up when there are cycles in the process-graph. e.g. Process Track A -> Bus B -> Track A. A common mistake causing this is trying to “insert” a bus in a track.

This is still mysterious. So it’s not at 00:15:00:00 on the timelineline, but after 15-20 mins of operation, even when idle (transport is not rolling)? and save, quit, reload helps?

Every time I have experienced a similar issue I have been able to track it down to a plugin, and it has been a while as I haven’t used those plugins in some time. That is still my most likely culprit, but not the only possibility.

      Seablade

Yes. 15~20 mins more or less, of operation even when idle. Save is possible most of the time but I did experience a session which the save did not work when I reload.

I am trying out the plugins that I have for this session as suggested. Hopefully, I can have a conclusion this time.

Guys, Thank you for the suggestions and advice!