Ardour looking for Suil in the wrong path

Today I installed Ardour (from git) on my Gentoo system and due to a bug in the lsp-plugins package I had to downgrade LV2 as a workaround, and for some strange reason after recompiling Ardour to make sure there was no issue moving to this older LV2 version, plugins just stopped opening their GUIs and after some debugging I found out that Ardour was looking for suil in /usr/local/lib/ while the suil-0 directory is actually in /usr/lib64/. I tried uninstalling lv2, ardour, suil, etc… but to no avail. In the end I tried making a symlink thinking it would fix things, but only partly. Some plugins opened but crashed Ardour when trying to close them, some plugins hanged for a long time and then opened, and some plugins worked. I have no clue why this happened by just downgrading lv2. Any clues?

Downgrading Suil fixed it.

This issue with suil 0.10.14 was reported upstream, see modules are not found when installing suil in /usr/lib64 (as opposed to /usr/local/lib) (#5) · Issues · LV2 / suil · GitLab

Fellow Gentooer here, the latest lv2 did not install a header file, and most package would not compile against it. There is already a fix upstream, see Fix lv2.h missing from installation · lv2/lv2@e499639 · GitHub