Ardour keeps telling me my hard drive isn't fast enough

using a micron ssd and keep getting this message,telling me my hard drive isn’t fast enough. I thought ssd are faster than old sata hdd. but alas I can’t record yoshimi arpeggios. I get the message.how fast does my ssd have to be to not have this problem? My brand new computer with a micron 1TB ssd, is not fast enough? I thought ssd are faster than hdd. What?

Yes SSDs are plenty fast. I’ve never seen this message, do you have a screenshot? Which version of Ardour? Is it from the official downloads or did you get it elsewhere?

Correct, if you are seeing that message it is because of a problem with system settings, not because the SSD actually isn’t fast enough.

What OS, filesystem, are you using disk encryption, etc.?

I am using Ubuntu 22.04 studio and no disc encryption that I know of. Files are saved in Ardour format.

Ok. I shut down the session I was working on. I restarted ardour and tried to duplicate the problem and it went away. It might have been that I had already recorded 6 other tracks and was trying to add one more some of them computer intense. But I can’t make it happen with one track.

6 tracks shouldn’t be enough to cause issues on ANY properly set up system much less a ssd. There are some SSDs that have issues with clearing data to make room to write new data, particularly on the cheaper end of things, is it possible you might be running into this? It might cause pauses that would cause such an issues