Ardour/JACK configuration for Envy24 (hoontech adc2000)

So I’ve finally decided to take the plunge and move my audio workstation over to Linux, as I’ve been a long time Linux user (both desktop and server), and have just installed Ubuntu Studio. I’ve run into a bit of a setup issue, and am hoping someone that’s running an Envy24 based card will give me some hints on how to get all my input/output channels configured in JACK so I can begin trying out Ardour. I apologize if this has been covered elsewhere, as I did search but found nothing relevant to my issue.

So far I have been able to configure JACK so it appears I am receiving an input signal (I’m running envy24control from the command line and can see the meters respond on the input side), but I’m not hearing anything from my monitors. I’m basically just loading up Audacity and playing a .wav file for testing purposes. I’m not sure if I have the output channels configured properly - in JACK I have the “Input device” set to hw:0 (which is the “Hoontech Soundtrack Audio DSP24”) and the “output device” set to the same thing. Previously, in Windows I would use the small “patchbay” tray application to “enable” the DSP2000 break out box, but I don’t see an equivalent application to do this, nor do I see anything in JACK.

If anyone else has configured the hoontech device (mine is a rebranded “STA Audio ADC/DAC 2000”) and would be willing to share how they set it up it would be appreciated.

Thank you!

  • Brian

Envy24control has a routing-panel and several not very easiliy understandable mixing-panels.
On my boxes I have to adjust the “Analogue Volume” strips to get proper in/out. If you have a breakout-box, chances are, that you need to fiddle a bit with the PCM-mixer and change the routing to digital mix R/L.

nostrum fungitur

Thanks nostrum - I think I’ve made it a step farther. I can see now that the output works in Audacity if I choose the “Hoontech ICE 1712 consumer (DS)” output (although I believe that is the small 1/4 inch stereo PCI card output, not outputs 1/2 on the breakout box).

I’m also thinking that Audacity bypasses JACK, as I’m able to record and playback sound within Audacity even if JACK is not running. So I guess the issue (still is) to get JACK configured to work so I can use Ardour. I know this may be a stupid question, but are there any “meters” within Ardour that I can fire up just so I can see if I am getting an input signal? That’s why I have been using Audacity, since I couldn’t find any input level meters in Ardour…


  • Brian

start a new session and type Shift-E (or use the menus: View -> Show Editor Mixer) to get a mixer strip in the editor window. alternatively, type Alt-M (menus: Windows -> Mixer) to bring up the mixer window.

Thank you paul - that helped. I’ve managed to get all the inputs working on the c-port, but I’m still not able to use the hoontech (c-port) as the “output”. What I’ve got working is to use the on-board nforce2 audio to hook my speakers up to, which will work in the meantime but it’s not as flexible.

If anyone has the hoontech/c-port/staudio DAC2000 working fully in JACK I’d love to know what you’re using for your output in the JACK config.


  • Brian

Try the qjackctl setup page and see which devices are listed when you press the ‘>’ button next to the audio interface selection. Maybe the breakout box is represented as a subdevice on the driver.

Also, if you feed an input signal to the breakoutbox, do you see that input signal with envy24control?

Hi jamroom

I have a working C-Port 2000 using Linux. How can I be of help?

Can someone give me a hand getting this card to work under ubuntu. I know the card works, just ‘jack’ … Any help would be greatly appreciated.

I am a newcomer to using jack and have the dsp2000 … Is there someone who has some experience using this card with ardour? I’d like to configure. Perhaps someone knows of a Jack tutorial/reference available?


I have been using the Hoontech on linux for 2 years with Ubuntu Desktop (currently 8.10). If I remember correctly, the sound card worked immediately after installation, and I have rarely experienced any problems.

Here are some settings that can help you :

  • Try and disable the internal PC audio card (e.g. AC97) in the BIOS.

  • If you haven’t already done, install the package “alsa-tools-gui”

  • Launch the “envy24 control” utility.

    • Under the “Patchbay/router” thumbnail, set “HW out 1” and “HWout 2” respectively to “Digital Mix L” and “Digital Mix R”.
    • Under “Monitor PCMs” mute the right slider in the “PCM Out 1” track and slide up the left slider to 0. Do the opposite in the “PCM Out 2” track.
    • Under “Hardware settings” select “Professional” in the SPDIF/output settings

Now you should be able to hear some sound via the headphones and your monitors. Try and listen to a CD or any other source.

  • Launch Jack via the qjackctl graphical interface
  • If jack doesn’t start, try and disable ‘real time’ in the settings. (for instance, Ubuntu 8.10 doesn’t have a realtime kernel)
  • In my configuration, jack works well with ‘(Default)’ as interface, input and output device
  • If jack complains about the sound sequencer being busy, open a terminal and type: “sudo alsa force-reload”.
  • In any other program, if asked to choose between “Professional” and “consumer” modes, use “professional”. Apart from being better for one’s ego, “consumer” settings always seem to … dysfunction.

I am not an expert, these are some solutions I have found by ‘googleing’, and out of ‘trial-and-error’, about the few problems I have experienced. I can’t guarantee you that they will work for you too, because honestly I don’t remember why they are supposed to work…

All I can say is that my card works much better than on XP. Please let me know if some of these advices were useful.

(To others : if anybody knows better than I, please post your info!)