Ardour is not detecting Carla for me

Hello:

First of all, congratulations: Ardour is simply phenomenal!
My problem:

I installed Carla by doing sudo apt install carla

When I open Ardour 6 and click “insert plugin” on my midi track, Carla doesn’t show up on the list. The same thing happens with Calf, but Carla is more important to me.
Carla is fully functional stand alone, no issues there.

Thank you very much in advance.

Hi!

If, for example, you are on Ubuntu, the LV2 and VST plugin versions of Carla are “recommends” and not part of the carla package so maybe double-check they are installed by typing sudo apt install carla-lv2 carla-vst. (I’m not on Ubuntu so can’t say whether the package manager automatically installs these “recommends”)

Ardour should detect the LV2 automatically but you might have to re-scan for the VST plugin.

1 Like

Thank you very much.
I already had tried this but it says those recommends are already installed. I am on Pop!_OS 20.04 tuned with the latest kernel.
This is weird indeed, but I will post if I arrive to a solution.

Where did you get your version of Ardour 6: from a repo or as binary from this site?

I’ve got it from a repo, it is the curated version.

BTW:
If I do find / -iname ‘carla’ 2>/dev/null
It shows that carla is installed on /usr/lib/vst/

However, Ardour doesn’t see this path when I go to preferences and try to edit the linux vst path, so I cannot set it up.

Could this be a permission thing?

EDIT: I correct myself, this is a flathub version downloaded via the Pop Shop

UPDATE: reading a bit, I am almost positive that this is related to flatpak sandboxing and having to execute a flatpak --override

That sounds right! I’ve not tried the flatpak version but was having some discussion about it on the IRC yesterday. Let me know if that fixes things for you :slight_smile:

I tried doing:

flatpak override --filesystem=host org.ardour.Ardour

But no luck.

So, I deleted the flatpak, and installed Ardour 6 by adding ppa:ubuntustudio-ppa/ardour-backports. Now it works!

Not sure if this is a problem with flatpak or Ardour’s flatpak version itself, but I advice the devs to look into it if they can.

We have nothing to do with any flatpak for Ardour, nor with any distro provided version.

The only official version of Ardour, and the only one we provide support for is the one from http://ardour.org/download

1 Like

This is great news—enjoy jumping into Ardour + Carla! As per @paul’s comment, I can heartily recommend switching over to the Ardour binaries on this site if you are able :slight_smile:

1 Like

Thank you very much. I am sorry, I had no idea you could buy Ardour! This is great!

Cheers.