Ardour installed, no sound for playback

Hello!
I’m new in a band and I have to record drums. I want to use Ardour to import guitar tracks that someone sent to me, and record with edrum kit via MIDI.

I use Ubuntu 22.04 and for days I’m browsing just trying to get a clear answer if I can use Ardour for my purpose (I read in couple of places that works perfectly for many purposes but not for edrum recording, but that sounds strange to me).

I have installed through apt-get, version is “Ardour 7.1.0 “Music for Films III” (rev 7.1) Intel 64-bit”. I imported the guitar tracks before pluging my edrum kit or anything, but I cannot get playback sound. The track is read, and the signals are marked, but no sound.

I am willing to use the audio card integrated in my motherboard. I have run the script from the ardour community and this is the output I got:

========================================
Part I: ALSA
Advanced Linux Sound Architecture Driver Version k5.15.0-52-generic.

Card 0 (sofhdadsp):
  * Playback Device 0:
    - Subdevice 0 (hw:sofhdadsp,0,0):
      closed

  * Playback Device 1:
    - Subdevice 0 (hw:sofhdadsp,1,0):
      closed

  * Playback Device 3:
    - Subdevice 0 (hw:sofhdadsp,3,0):
      closed

  * Playback Device 4:
    - Subdevice 0 (hw:sofhdadsp,4,0):
      closed

  * Playback Device 5:
    - Subdevice 0 (hw:sofhdadsp,5,0):
      closed

  * Recording Device 0:
    - Subdevice 0 (hw:sofhdadsp,0,0):
      closed

  * Recording Device 1:
    - Subdevice 0 (hw:sofhdadsp,1,0):
      closed

  * Recording Device 6:
    - Subdevice 0 (hw:sofhdadsp,6,0):
      closed

  * Recording Device 7:
    - Subdevice 0 (hw:sofhdadsp,7,0):
      closed

========================================
Part II: jack processes

When I open a session, this is the proposed setup, which I just accept:

image

I click on start, I import a track:

(sorry because Im new I can only paste one image)

I play it and no sound.

Because some people recommend using jack, I have tried to install it, but didn’t know what do with it, so ended up uninstalling it.

If there is anyone there who could help me to understand and set up my Ardour to work for my purpose I would be super grateful.

I’m using the demo, and willing to subscribe once I check that it can be used to record my drums.

Thank you in advance!!

This is the image I could not paste in the message above, in case it helps:

Maybe try changing the Output Device to something other than “sofhdadsp,3”

Some people also reported a bit weird behaviour of the sof device here

Thanks, I actually had tried with all the combinations, with same result.
I followed the link you posted, but I have to say that I do have audio in ubuntu from the system, I can listen to videos and music in other applications etc. My problem is only with Ardour.

ha, so it was a really stupid thing after all.

I had my headphones connected via BT, so that will skip the ALSA drivers.
Once connected the wired ones I don’t have a problem anymore.

2 Likes

Thank you for coming back and letting others know what solved it. I don’t think most people bother, which leaves the impression that the issue is still lingering and may be affecting other users.

1 Like