Ardour installation problem

Hi, i’ve just downloaded Ardour and unpacked it to my desktop folder, then i’ve executed:
chmod +x
in terminal to make install script executable and then
sudo ./
but terminal wrote me the following:
./ 25: /home/pocek/Desktop/Ardour_64bit-3.1.10-dbg/ Permission denied

What am i doing wrong?
P. S.: I’m sorry for my english

Did you by chance unpack it with sudo? You probably shouldn’t if you did.


chmod +x
should help.


Thank you guys, problem was solved after i downloaded ardour again and executed:
sudo ./

@videogames_guy: you’ve unpacked it onto a filesystem where you do not have execute permission. This will not work. Ignore @jano’s suggestion.

There is reason to use sudo to run ./ (and the instructions do not ask you to do so).

As I had the same problem, allowing to be executed worked. Is there a way to have no execute permissions on your desktop folder?

I’m sorry if I had the wrong attempt, but as I said, for me it worked.


The problem is, as Seablade suggested, that you used sudo to unpack the tarball, which made the install scripts be owned by root. To run them after that you need to be root again, so when you used sudo again, it worked. You should be sparing using sudo, particularly when you don’t know what the command you’re about to run will do.

Hi, finally I have the ready-to-run file version. I unpacked the tarball (with my user - not sudo) but the next message appears. “bash: ./ Permiso denegado”
I tried to dragged and dropped to the terminal but nothing happend. I must to copy files in another directory?
Many tks and brgds

renzogiova: what is the output of: ls -l ./install/sh and also df -h . ?

that should be

ls -l ./


$ ls -l ./
-rwxr-xr-x 1 renzo renzo 798 2013-06-13 12:24 ./

df -h .
S.ficheros Tam. Usado Disp. % Uso Montado en
/dev/sda3 177G 165G 3,7G 98% /mnt/cajita_feliz


@paul / @seablade: do you know where should be the error? I tried to free my disk to have more space but nothing new happend. Do you think there is a permissions issue? Thanks and brgds

@paul / seablade: finally I intalled a new version of Ubuntu and tried again with Ardour. It works! Thanks for your time and brgds

I had the same problem that was mentioned at the begining of this thread. Finally I downloaded Ardour again and somehow it worked.

Here is the step by step… if you are like me that is, not having memorized every command to navigate with terminal:

  1. download Ardour
  2. Extract to desktop
  3. Open a Terminal
  4. type in “cd ~/Desktop/Ardour_64bit-3.4-dbg” (without " " )
  5. Run installer “sudo ./” (again without " " )
    this should work and place a nice little Ardour shortcut on you desktop

You just have to select show hidden files.