Ardour in Ubuntu 11.04

ok so i would love to come to linux but i’ve run into a small issue

i wanted to run ardour with vst capability so i downloaded the source code and compiled with every option i could. It looked like it compiled just fine and then i installed it. all the other options like freesound, lv2 etc… seem to be there and i want to see if vsts work but i can’t seem to find a way to install the vsts. i’ve read some other stuff on the topic and it says to create a folder and have that link to the vst folder that ardour looks in. this is where i get stuck. i’m still new to linux in general and i’m not comprehending how to do this in general.

i also read that you should be able to start this version from from the command line with “ardourvst” but it’s telling me it doesn’t exist. If that were so then why when i run the normal ardour from clicking on the icon all the other options i compiled into it are all there?

If you have any instructions to post please act as if i’m a complete moron and make them as specific as possible. I really like this program in every other respect so far and would love to use it and finally dump windows completely.

My advice for a Linux newbie (or even an experienced hand) is that if you want to do music with Linux start with a Linux distribution which is already tailored to music production and bypass these sort of compilation/configuration headaches. While it is possible to run Ardour and other music software on any Linux distribution you’ll save yourself a lot of trouble using something like AVLinux which has ArdourVST and a lot of other music software working out of the box. You can run AVLinux from a bootable DVD or install it to a new partition so you can keep Ubuntu. AVLinux is of course not the only choice for a Linux music distro, but I’ve had very good experience with it.

that’s cool and everything but i’ve already put in so much work just getting my firewire soundcard working well with ubuntu and it would be a shame to just to junk it and start again from scratch.

Is there anybody that can help me resolve this particular issue?

ok for some reason i don’t see any ardourvst in my folder where it should be.
here’s what the output is in terminal when i run scons install:

scons: Reading SConscript files …
Checking for pkg-config version >= 0.8.0… (cached) yes
Checking for lrdf… (cached) yes
Checking for libgnomecanvas-2.0… (cached) yes
Checking for gtk±2.0… (cached) yes
Checking for jack… (cached) yes
Checking for sndfile… (cached) yes
Checking for samplerate… (cached) yes
Checking for gthread-2.0… (cached) yes
Checking for libxml-2.0… (cached) yes
Checking for raptor… (cached) yes
Checking for glib-2.0… (cached) yes
Checking for fftw3f…(cached) yes
Checking for fftw3…(cached) yes
Checking for aubio…(cached) yes
Checking for C header file fftw3.h… (cached) yes
FREESOUND support is not enabled. Build with ‘scons FREESOUND=1’ to enable.
Checking for slv2… (cached) yes
WIIMOTE not enabled. Build with ‘scons WIIMOTE=1’ to enable support.
Congratulations, you have a functioning C++ compiler.
system triple: x86_64-unknown-linux-gnu
Checking for C header file fftw3.h… (cached) yes
Checking for usb_interrupt_write() in C library usb… (cached) no
Checking for C header file linux/input.h… (cached) yes
Checking for C++ header file boost/shared_ptr.hpp… (cached) yes
Checking for lo_server_new() in C library lo… (cached) yes
Checking for dmalloc_shutdown() in C library dmallocth… (cached) no
Checking for C header file alsa/asoundlib.h… (cached) yes
Disabled building Tranzport code because libusb could not be found
Checking for internationalization support …
Found xgettext
Found msgmerge
Checking for C header file libintl.h… (cached) yes
International version will be built.
Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Versions/A/Headers/CoreAudio.h… (cached) no
Checking for C function posix_memalign()… (cached) yes
Checking for C function gtk_widget_set_tooltip_text()… (cached) yes

scons: warning: Ignoring missing SConscript ‘manual/SConscript’
File “/home/torque/Desktop/ardour-2.8.11/SConstruct”, line 1404, in
Checking for C function getmntent()… (cached) yes
Checking for C header file execinfo.h… (cached) yes
Checking for jack_client_open()…(cached) yes
Checking for jack_on_info_shutdown()…(cached) yes
Checking for jack_recompute_total_latencies()…(cached) yes
Checking for JackVideoFrameOffset in jack_position_bits_t enum…(cached) yes
Checking for jack_port_ensure_monitor_input()…(cached) yes
Checking for C header file wordexp.h… (cached) yes
Checking for C header file sys/vfs.h… (cached) yes
Checking for C header file /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h… (cached) no
Checking for C header file /System/Library/Frameworks/AudioToolbox.framework/Headers/ExtendedAudioFile.h… (cached) no
Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Headers/CoreAudio.h… (cached) no
Checking for C header file /System/Library/Frameworks/AudioUnit.framework/Headers/AudioUnit.h… (cached) no
Checking for jack_set_thread_creator()…(cached) yes
scons: done reading SConscript files.
scons: Building targets …
scons: `install’ is up to date.
scons: done building targets.

does this help?

If the ‘find’ command didn’t find any file named ardourvst you probably forgot to add VST=1 when you ran scons the first time. Either that or you don’t have the wine-dev package installed. See the official vst building document :

Also note that since you seem to be running a 64 bit distro you will only be able to run 64 bit VST plugins (unless things have changed since these replies from Paul :

Based on my experience of trying several other distros first (Ubuntu, 64 studio etc) I still think Edward Diehl is right that you should try AVLinux. Unless there is a real show-stopper with your sound card you are likely to have a system working and recording music sooner that way.

as noted on IRC, VST support will not work on a 64 bit system. Almost all Windows VST plugins are x86 ONLY and cannot be hosted in a 64 bit host without a lot of cruft that I’m not interested in trying to provide myself.

If you did run ‘scons install’ ardourvst should be in /usr/local/bin.
To check for that, run ‘find / -name ardourvst’ and you’ll see where it is.

VST dlls should be put in /usr/lib/vst or /usr/local/lib/vst, if you start ardourvst from a terminal it will print where it looks for them.
Since you have to be root to put things there an option is to put them somewhere in your home directory, say in a directory called VST, and then run
‘export VST_PATH=~/VST ; ardourvst’

well i know the problem now
when i installed with wubi it installed the 64bit version by default
so i installed the 32 bit version and compiled the program with vst
now i have a new problem so i’ll start a new thread regarding that
thanks guys