Ardour idles at high CPU usage

I’m seeing high idle CPU usage in Ardour when idling. Monitoring is external, so any possible plugins should not come into play (except for reverb decays of previously stopped material). Toggling DC offset to tackle denormals mitigates the situation somewhat, but it doesn’t entirely fix the issue. Switching between denormal management methods does not yield appreciable results.

This is not true. Ardour is constantly running all plugins to process audio, UNLESS you enable ‘Stop Plugins on Transport Stop’ in the preferences (Under Plug-Ins/General). This is not the default intentionally.

      Seablade

If I do that I lose the reverb decays though. Wouldn’t it be possible to implement a hybrid approach, where plugins are muted when output = input for a set amount of ms?

That’s incorrect. “Stop plugins on transport stop” does not mean “do not run plugins after transport stop”. It means “reset plugins (tell them to stop and reset) at transport stop, and the keep running”. This is in contrast to “just keep doing what you’re doing, even though transport is stopping”, which as the OP notes, is necessary to hear reverb tails.

Ardour is specifically designed to do all audio processing at all times. The only way stop a track or bus from contributing to the DSP/CPU load is to make it inactive.

Oh and does the setting apply when recording? I’m using Ardour to record my band’s rehearsals and so typically all the tracks are record armed and not playing when recording (and neither are they outputting any data as monitoring is disabled).

Again, Ardour does all audio processing all the time. This is intentional - we do not want users to get sudden surprises when the DSP/CPU load spikes due to changes in the processing being done.

You can drop out of recording (or mute) at any time, and we expect you to expect to hear exactly the right thing when you do.

So, is there a solution to this that allows you to keep plugin-related CPU usage at a minimum during recording? I’d expect a high-ish CPU usage to potentially cause xruns (or at least facilitate them). Or maybe there is a post-processing toggle that allows you to disable FX across the board?

You can load a session with all plugins disabled (“Safe Mode” at the bottom of the session selection dialog). There is no switch in the program to turn them all on or off.

1 Like

Ahha thank you for the clarification, I was actually going off memory and had typed that first, then deleted it thinking it was wrong. I wasn’t 100% on the exact behavior but I was thinking it was how I described. Either way the plugins are still running in the OP:)

     Seablade

This could be an interesting use for a LUA script though.

As of right now I try not to run many plugins, especially verbs, when recording. Of course I do a lot of tracking of live events so I end up running 0 plugins in those instances, but even for more traditional studio tracking I try to not run much in the DAW and instead focus on what is outside. On the flip side of this though if I have my machine operating correctly I should be fine to run whatever I wantin the DAW provided I stay under 100% DSP (Realistically I don’t go over 80% though).

In the OP’s case I wonder if proper usage of template sessions wouldn’t be a good solution, but it is hard to tell what the exact needs in the rehearsal room are. If it is literally only recording, then yes run a template session to create a new session each time.

If you need to have a different option one thing off the top of my head that might be interesting to try would be to run two sets of tracks, each pair with a shared playlist, one with plugins on, one with them off. Then disable the plugin tracks when recording, and the dry tracks otherwise. Not sure if this would work well, and can’t remember if the active switch on tracks is affected by groups or not so it may not make things any easier if not.

    Seablade
1 Like