Ardour freezes in export

I am mixing 4 tracks of music with Ardour in Ubuntu, using effects and every time that I try to export the music, Ardour sort of freezes, and I get a .wav file with just a few bytes. Is is possible that this is a render problem? Is it possible to render the effects in Ardour or it happens automatically. Weird thing, when I delete the effects, the export works.
Thanks in advance,

hello everyone,
I’m experiencing exactly the same problems with ardour using a fedora 16. It is not clear why arour and jack freeze both when I want to export a .wav file.
I find strange that the exporting step was ok at least ten times before and most of all, sometimes jack and ardour freeze both and sometimes it’s only ardour while jack is still OK.
I uses only three effects, EQ10, compressor and reverb.
All the tests for jack seem to be successful, I am running short of ideas to locate the problem

Thank you very much is anyone has a suggestion

You might also try removing each effect until things start working...

I did this step-by-step removing and it appears that ardour freezes during export as soon as Invada Early reflection Reverb is launched.
What is tricky is that I have the feeling that once you have create one bus with this reverb you have to remove all effects busses to succeed in exporting again.
For the moment with only EQ10 and Invada compressor it’s OK for exporting. It seems to be OK as well when I add Gverb. I’ll try with other tracks, because for the moment I work with the drum kick only.

So far so good.
Thank’s a lot

EDIT : After several others tests, it appears that ardour freezes as soon as there are more than 3 busses with EQ10 plugin.
I think I correctly use busses for applying effects for several tracks but we never know.

Hi !

I’m experiencing the same issue (using mixbus 2.0.7 demo), and I found that when I delete the “Gverb” effect plugin from inserts, the export don’t freeze.

Actually, it seems to be an issue with Jack, because when the export freezes, Jack is frozen too, and if I want to restart Mixbus, it says that “Mixbus could not start JACK”. So I have to kill both Mixbus and Jack, then reboot… If I don’t reboot and just try to restart Jack, it won’t start anymore, some errors appear.

What is strange is that I already successfully export some sounds with this effect, in the past…

So, until fix, I won’t use the Gverb effect.

Bye all

EDIT : hum, actually I tested without any effect, and… It won’t export NOTHING !! It drives me crazy…
Jack report an XRUN, and Mixbus freeze. But now, I can shutdown Jack and restart it without having to reboot.

Re-Hi all,

Finally, I solved this problem by using “jackd1” instead of “jackd2”… I found this on a linuxaudio forum, tried, and it worked, even with the “Gverb” effect inserted on a bus.

Hope it’ll help somebody !

Not sure what the problem is regarding jack2, but its probably worth mentioning that jack2 is not an incremental improvement / update on jack1, but more a fork of jack1. My personal experience has been that I have had much better experience with jack1 (but I’m sure there will be others for whom the reverse is true - such is the nature of trying to assemble all the components of a working PC based DAW… on any OS… )

Weird thing, when I delete the effects, the export works.

Then what you’re saying is that one of the ‘effects’ might be in some way responsible. So… which effects are you using?

You might also try removing each effect until things start working… Which often gives a clue as to which effect is responsible…

Maybe my comment is a little late, but just in case the problem for someone persists I suggest the following work around:

Instead of exporting the session, record the output of the master bus into a Ardour track called “Master Track” or something like that. Then export only this Master Track without effects. If you want, apply some automation for fade out.

I have the problem even with midi desactivated…

Jackd1 solved my issue. Thanks to Polosson

same here with Mixbus 2.2 on kxstudio…

Hello everybody,
for me it’s the same, without any plugin added to Mixbus 2.2.0.
I achieved a first export, and when I tried to do a second one, ardour crashed everytime. I have the same export parameters.

It happens when I engage the “generic midi” option in the control surface tab. Actually it seems logic, I don’t know why…
The program should wait for something from midi and can not do his job… When turning this option off, everything works good.

PulseAudio can really mess with exporting (and just about everything else.) I’ve seen it slow the export process down to a few SAMPLES per second. When this happens, Ardour appears to hang, but it’s actually exporting very slowly. In this case, you can cancel the export and regain control of Ardour.

If you have PulseAudio installed, either remove it, or disable it via `pasuspender’, and see if that helps.

I’ve been able to disconnect the PulseAudio module via qjackctl’s ‘connections’ interface, and this seems to clear things up, as well.

yes thank you, i’ll try that.

I also have this issue using jackd2. I need it for running properly skype and other stuff. Any way to get Ardour export working with jackd2 ? I don’t have any effect, just one midi and one audio track. Not able to solve the problem even if pulse is not running…

thanks to dennismtaylor…pulseaudio was the culprit in my case.
I have this line in qjackctl in the script after startup box:
“pactl load-module module-jack-sink channels=2; pactl load-module module-jack-source channels=2;pacmd set-default-sink jack_out”
unchecking the box solves the problem