Ardour & Focusrite 2i2 problem

Hi there, I am new to Ardour but I have been running Fedora 39 for a while now and using Focusrite 2i2 3rd Gen with for my audio i/o requirements with never any problems. I have two speakers connected to the audio interface.
I recently started running Ardour 8.4 and I noticed that as soon as I start the session after selecting the Focusrite 2i2 as both my input and output device, all audio (ie. music, youtube) goes silent.
Ardour somehow acquires exclusive access to the audio interface, and locks out all other sound sources.
As soon as I end the Ardour session, the sound from other sources returns.
This does not seem right but I wonder whether this is normal behaviour (?)

I have installed Helvum to monitor the connections (I had no success with WirePlumber).

Before launching Ardour, the Focusrite node/device is visible and connections from the audio sources appear normal. However, as soon as I launch Ardour, the Focusrite node disappears from the Helvum display, and any sound from music or youtube source simultaneously stops.
Interestingly, even though neither Ardour nor Focusrite are visible as nodes on Helvum, Ardour works fine with the Focusrite device with both input and output. I can record instruments and playback is heard through monitors with no problems.
I would like to launch Ardour without losing the sound from other audio sources. If this were not possible I would at least expect to see Ardour and the Focusrite device displayed in Helvum.

Does anybody have any suggestions? I would appreciate any ideas. I am no expert… I know my way around Linux and Fedora but I am new to Ardour. I have looked at the Ardour manual but I am at a loss as to how to even begin to resolve this.
Thanks in advance.

Sounds like you are running Ardour in ALSA mode, which takes exclusive ownership of the audio device. Try selecting JACK mode (in the Audio|MIDI Setup dialog, either as you start Ardour or under the Window menu).

1 Like

This is expected behavior. Ardour does not want any other application to be able to change settings (sample-rate, buffersize) while you are doing pro-audio work. Also no desktop sounds should be able to reach monitor-speakers, or interfere when recording.


If you want to share the soundcard with other applications, you have to use JACK or pipewire/JACK.

1 Like

Many thanks for your reply. I suspected as much. I just wanted to be able to listen to YTube Ardour tutorials while I delved into it hands on.
I tried JACK instead of ALSA but there was no sound. I think this is a beckoning for me to dive into understanding audio in linux.
Thanks again for your help :slight_smile:

You could use the onboard soundcard for that (this is how I usually work, laptop’s built-in for desktop audio, USB soundcard for pro-audio). …or just stop Ardour’s audio engine (Menu > Window > Audio/MIDI Setup) while watching videos.

1 Like

Good idea. I think I will rescue my old speakers from storage and plug them in to the onboard soundcard. Thanks for the suggestion.