Ardour failure to launch ubuntu studio

Ardour 6 launch window just sits there saying “Loading . . .” No activity on hard drive. Tried running from terminal and got the following failed attempt.

likely: 0005605: Hangs while starting at loading UI config files - MantisBT

Try export GTK2_RC_FILES=/nonexistent before starting Ardour.

PS. with recent Ardour 8.6 this won’t be an issue anymore.

nope. But thank you for your time and effort.

This will not happen with a build from ardour.org. Either get a build from there, or talk to your distro’s package maintainer.

What version of Ubuntu Studio are you using? It looks like you are running Plasma/KDE. I am on Ubuntu Studio 22.04 with KDE Plasma 5.24.7. I do not see issues starting Ardour 8.6.0 although it does occasionally crash immediately after startup when I resume the system from hibernation. A fresh restart always fixes that. Here is what I see when launching Ardour from the command line:

hey there. I was able to work through the issue so far by suggestions and trial and error. Bottom line is I wound up removing Ardour6 off my UbuntuStudio install with all associated files. I had to install Flatpak and used that instead of Snap. Once I got everything cleaned up and ready I did a new install in terminal by running ‘flatpak install ardour’ followed the Y/n prompts and it installed a new updated Ardour 8.6.0. Rebooted and ran it. Worked perfectly so far(knock on wood). So beginning my journey to learn Ardour now. Thanks.

Note that the flatpak will have various issues, notably when using plugins. You will also get the flatpak version of those, and then may still run into various issues.

We do not support the flakpak version of Ardour. You’re on your own there.

Thanks for your input. See reply to ‘Robin G’ below. I’ve only just ran it once and looked over settings and verified my audio interface and nektar mini keyboard in preferences. Glanced through part of tutorial. Thanks for your reply and input.

Thanks. I’ll have to deal with it as it comes and learn as I go. Not sure what you mean by not supporting the flatpak version. This is all new territory for me just moving from Windows 10. Wish me luck and stay in touch please.

The official build of Ardour, the only we can actively support, has to be downloaded from Download Ardour | Ardour Community

Versions that you get from your Linux distro (e.g “the flatpak version”) are fine, but we can’t provide support for them if/when you have issues. For that you’ll need to rely on the package maintainer on the Linux distro you’re on, and/or the kindness of strangers here.

I understand. So far the kindness of strangers here seems invaluable. Thanks to all responders.