Ardour fails to start if network not connected.

Running Ubuntu Studio 9.04/Ardour/Jack/Firewire/Presonus FP10. I’ve been very impressed with Linux/Ardour and have used it successfully both at home and on-site over the past year or so. However, I now have a very strange and extremely frustrating problem. All was working fine at home, went on site to record, start Jack, Start Ardour, select session I get a few Ardour splash screens, the last one being to do with OSC startup and then Ardour disappears. I was then forced to revert to an inferior XP system. Came home and all was fine again. Went on site a few days later and suffered a repeat of above failure which does not look good in front of waiting musicians! Had to use XP again. The following message appears in Jack messages:
subparagraph starting at ardour timed out(subpragraph_wait_fd=21, status=triggered,pollret=0,revents=0x0)
I finally worked out that Ardour starts up and works OK only if a valid network connection is present. If I unplug the network connection to my home hub (router) Ardour will not start - plug it back in and “normal” operation is resumed. It doesn’t need any other computers connected to the hub, it doesn’t even need to be connected to the 'phone line. As long as it sees the hub it works, if not it won’t work! I guess I can work around it by taking the hub on-site with me just to satisfy the apparent need for a network check, but its not really very satisfactory.
I’ve tried reloading Ardour and Jack, but all to no avail, I’m on the verge of a complete 9.04 re-install, but really need to find a solution to this problem otherwise it will recur I’m sure.
If info from event viewer will help, please let me know which you need.

Many Thanks for a great product.

I think you’ve got a problem with your network configuration. Ardour absolutely does NOT require a network connection, but the OSC discovery/setup phase will go wrong if your machine is misconfigured. Typical errors include mis-identifying or duplicate entries for “localhost” in /etc/hosts, but there are other causes. One workaround is to edit your ardour.rc file and disable OSC. That is, however, just a band aid for a deeper issue.

Thanks Paul, you were absolutely spot on! I had been thrashing around trying to get my home network to see my Linux machine and suspected a …/etc/hosts issue. I thought I’d backtracked all the changes I made and even went so far as to delete the hosts file to no avail. I’ve just re-instated the hosts file and saw that localhost was not assigned at all, in fact was assigned to mike-desktop. I’ve now assigned to localhost and Ardour now starts up correctly - an enormous relief!!! I realise this may not be the correct forum, but my hosts and …/etc/network/interfaces files look like this (don’t laugh): localhost mike-desktop.mshome

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
# mshome network gateway broadcast netmask MAINPC user-7g9jdbmuma


auto lo
iface lo inet loopback

Does anything look wildly wrong ? Should I go to another forum?

And again thanks, I really am so grateful for the Ardour fix.

I know this is YEARS after you posted this, but where did you get this /etc/hosts file???

I’m assuming that your private IP is 192.168.1.x.

Your netmask should be The one you have is a class A netmask.

You have your gateway as, which is on an entirely different network. You don’t need this line in /etc/hosts anyway. In fact, you also don’t need the broadcast line (which is also wrong), or the network line, (which is wrong).

And I wonder about the I have no idea why this is here, unless you are dual-homed (2 ethernet cards on individual networks, such as a firewall, router, or DMZ). I’ve only seen it on one other machine, and nobody knew why it was in that one either. Comment that one out and see if it fixes/breaks anything. It’s noplace like