ardour drops midi notes when looping

I was hoping the bug referenced in
would be fixed in Ardour 5 but I see it’s still a problem. The issue is dropped midi notes at the beginning of a loop so if you are playing C-E-F-G you only hear ----F-G unless you move the start point of the loop to a couple of notes before C, in which case you have extra beats in a measure. This makes composition very… challenging. Until it’s fixed I can’t use Ardour (I’m sorry to say), much as I’d like to. According to the bug tracker this is a Linux Mint issue but I have the same problem in Ubuntu Studio. Is there any possibility that this can be fixed? Best, Tom

The bug report doesn’t say that is fixed. It has nothing to do with Linux Mint. Posting to the forum about an open bug report is a bit redundant. If you want to participate in and/or be notified of changes in the bug status, please use the bug tracker.

I have been watching the bug tracker for months. Thanks, I’ll keep watching it and I’ll try to be more patient.

Have you tried moving the loop start marker a 128th of a beat or so before the note? If that works, it shouldn’t practically affect your perception while composing.

Thanks for the suggestion, adotm. Moving the loop start marker slightly ahead of the first note doesn’t work, unfortunately. :frowning:

As for redundancy – the statement “it has nothing to do with Linux Mint” is not on the bug tracker. Thanks for the additional info.
One workaround is to use an external sequencer to write the MIDI parts – Ardour’s “MIDI clock out” keeps the sequencer in sync – and then record the loops.
This works with a hardware sequencer such as Doepfer’s A-155 and even works with Ableton Live on Windows, which can be slaved via MIDI to Ardour’s transport. The latter isn’t ideal if your purpose in using Ardour was to move audio production exclusively to Linux, but it is a way to have working MIDI loops.

MIDI looping is already fixed in git (and nightly builds), and will be in the forthcoming 5.4 release

Excellent - many thanks!

I do not know if it is related or not, but I got dropped MIDI notes in 5.4 (on Debian Jessie). Not looped, just playing back. I might have, say, 5 or however many copies of a MIDI region, one after the other, and often the first note of every other one would be dropped, or such. I reinstalled 5.3 and the problem was gone. I tried this (install 5.4 then went back to 5.3) twice. I also tried recreating the region from scratch with the same result. This was a project originally created in 3 something (whatever is in the Debian stable repos).

Thought to add, this MIDI track feeds out to Yoshimi, then back into an audio track.

@dwrunyon: please file a bug report on and if possible include a simple example of a session in which this happens. In general, we do not pursue bug “reports” given in forum posts, and I would like to track this down.

OK, I will, and if it would be helpful I can upload an entire sample session folder to Google Drive and link to it in the report.

That would definitely be helpful. Thanks.

Thank you, for everything. BTW, I didn’t realize how small the session would be nor how easy it would be to include as an attachment in the report, which is the first I’ve ever filed anywhere, for anything. Again, thank you, even outright bless you, for all you have done and do.