Ardour doesn't recognize CollaB3 VST

Hi, I’ve just subscribe to Ardour and downloaded de program version 6.7. Also, I’ve downloaded the CollaB3 organ from Sampleson site, in order to have it working on Ardour, as LV2 or LxVST. On Sampleson website appears that it’s able to have in working as VST on Linux. Installing on Terminal I’ve installed de VST file in /usr/lib/vst . That’s the folder with my LxVST plugins, already recognized by Ardour. Don’t know how to make Ardour to recognize this one.
Thanks for your amazing work.

It works for me, I have it installed in ~/.vst

Perhaps re-scan plugins? Preferences > Plugins > Scan?
Maybe also clear cache and blacklist in Preferences > Plugins > VST.

On my setup this gets installed w/o the correct permissions.
Try # chmod a+xr

Thanks. I’ve tried already, but with no results.

Just tried this, and still not appearing in the plugin selector list. I’m just a musician, not a tech expert, but with some internet searchings and help on forums, some copy-paste, etc, I usually achieve to make the things work properly. But with this I have no idea what I’m doing wrong, so far.
Thank you anyway for your help. And forgive my writing in english, I’m spanish and sometimes my expression is not the best.

Which OS are you using?

I’m with Ubuntu Studio 20.04.2.

Have you tried it in another DAW or Carla?

I don’t even know how to use Carla. XD. I"m kinda newby. I used a installing tutorial here Installation guide - Libre Wave
When it comes to enter the location to instal the plugin, how did you do then? I entered the file path I guessed it was correct. The same I’ve got the rest of the LXVSTs.

I’ll try to get into Carla and see what happens.

I entered /home/dave/.vst

Cannot see in Carla, either. So maybe is an installation error. I think I try to desintall and reinstall again. But in a different way. What did you enter first. I went to the folder with the file, and entered the file name, but in order to give root permissions, I did it with the sudo first. Is this the right way?

Trying to reinstall on terminal this happens:
The error message is in spanish, it means "no writable (mode 0700, rwx-----)

I didn’t give it sudo, that’s probably not a good idea. I made the .sh file exectuable (I did it through the GUI by right clicking on it and opening the properties). Then I ran the .sh from the terminal.

Have you told Ardour to look in /home/usr/lib/vst?

1 Like

Well, for the moment I’m afraid I’ll be stick to my trusty SetBfree x42-plugin Hammond organ emulator. I was pretty excited about the CollaB3, but it seems it doesn’t work with my gear.
Maybe I’ll give it a try later.
Thanks DHealey for trying to heal me. I really appreciate. :wink:

1 Like

CollaB3 is a hugh resource hog anyway. My DSP load goes from 15% to 90% just having it in a channel strip. You’re probably better off. That’s the same route I’ve taken even though I do have it installed.


1 Like

Wow. That would surely blow up my entire sistem. I rather wait until I have a more powerful PC.

Probably the location you are trying to install (the directory) does not exist yet.
The linux standard for filesystem names is that /usr/lib is for software provided by the linux distribution, and since most distributions have LADSPA and LV2 plugins available, but not VST, there may not be a /usr/lib/vst. Also depending on the distribution you are using the appropriate system path may be usr/lib64 on a 64 bit system rather than /usr/lib.

The accepted location for user or administrator installed binaries which are not available from the distribution repositories is /usr/local/lib or /usr/local/lib64 but that is a convention, not enforced. You could create a vst directory wherever you want first, and install CollaB3 there.

The Ardour manual contains a section on file locations, note that you can use the Plugins->VST menu selection to choose which directories you want Ardour to scan for VST plugins.
Ardour files and directories section of manual
My system is 64 bit, and uses lib64 for libraries, so I created the directory /usr/local/lib64/lxvst and placed my VST plugins there. I do not remember if I had to manually add that directory location to my ardour configuration through the menu or not. Possibly I did, but in any case it is working correctly on my system (that is other VST plugins work correctly, I have not tried specifically to use CollaB3).

I forgot to ask, which CPU are you using and is your OS 64bit?