Ardour doesn't play H2 Zoom usb device

Hello Everybody.

Really need help configuring Ardour/Jack to recognize H2 Zoom device. It plays fine trough Audacity and Ubuntu 11.04 (Sound Preferences) seems to recognize it very well. So it has to be something wrong with Ardour and/or Jack configuration.

Followed a number of threads to no avail, (tried a lot of configuration combinations)

This is the Output of one of those configurations (using H2 as duplex at 48k)

When i start Qjackctl :

18:52:32.075 Patchbay deactivated.
18:52:32.076 Statistics reset.
18:52:32.085 ALSA connection change.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
18:52:32.094 ALSA connection graph change.
18:55:26.894 JACK is starting…
18:55:26.895 /usr/bin/jackd -dalsa -r48000 -p1024 -n2 -m -D -Chw:1 -Phw:1 -i1 -o1
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Cannot create thread 1 Operation not permitted
18:55:26.926 JACK was started with PID=3887.
Cannot create thread 1 Operation not permitted
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
Cannot lock down memory area (Cannot allocate memory)
control device hw:1
control device hw:1
Acquire audio card Audio1
creating alsa driver … hw:1|hw:1|1024|2|48000|1|1|nomon|swmeter|-|32bit
control device hw:1
Using ALSA driver USB-Audio running on card 1 - ZOOM Corporation H2 at usb-0000:00:1d.1-1, full speed
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: cannot set channel count to 1 for capture
ALSA: cannot configure capture channel
Cannot initialize driver
JackServer::Open() failed with -1
Failed to start server
18:55:27.041 JACK was stopped with exit status=255.
18:55:28.972 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

Not very savy on audio things, but really determined to get this working. Can someone help?

Thank you


in addition to all of the above, please stop using the options to specify channel counts. these were not intended to be useful to most people, and may be removed in some future version of JACK.


I have a Zoom H2 and have found the best way to use it is to use the line out on it instead of the USB. It is a USB2 device and does not play well with Linux. However, if you use the line out it will use your laptop input or input on your desktop soundcard.

Then set JACK to use your onboard soundcard. It works well.


I wasn’t strong on detail, i know, but please tell me what output/screenshots you need to help me trough this…


To clarify if I was not clear. I use the H4 only as an interface for its microphones and plug its line out into the line in on the laptop. So, in JACK use the internal soundcard which is getting its signal from the line in which is coming from the H4 microphones.

You can then set the sample rate for the internal card at whatever setting it can handle because it is getting only a line signal. I do not use the H4 with Linux as an USB device at all.

If I was clear and you tried that already then I am clueless (my normal state actually).


Ok Thank you all. I now can run ardour again with H2 using it’s line out directly to laptop’s sound card (eventually it stopped working for some reason).

But when i try to chose an usb device as output (for monitoring purposes), in this case a creative soundlabs usb sound card, i get same error as posted above with the H2…this is weird to be…and because being clueless is too a thing of mine, i’ll keep banging my head against Jack’s till it stops picking on my usb devices…

I’'ll focus on having a decent way to monitor the output for proper multi-track recording. If you have tips please let me know, I’ll probably start a new topic and keep my newb-nagging organized :slight_smile: .



Perhaps pulseaudio is getting in the way? I used to have to do: “pactl suspend-sink 1” on the command line before I could start JACK nicely. I’m not sure what the state of it is in the latest Ubuntu, though. You might have to download the pulseaudio-utils package before you can use the pactl command.

I also have a H2 and just tried it with ardour3. Seemed to work okay, although i got too much latency which would have to be corrected for. I’ve never used it as an interface before, but seems to work okay in my quick test. With this device I normally record things and then copy the files over. System is fedora15.

Try this:
1-close all audio using programs including web browser etc while you trying to figure this out
2-connect h2 and select sample rate. i use 44.1k
3-start qjackctl and click on settings
4- change settings to something like this: Frames=512, Sample rate (match device) 44100, periods=3, input device (select device) something like hw:1,0, output device=same as input device. click save as preset. okay to save settings.
5-start qjackctl. if it starts up and runs without errors you should be fine.
6-start ardour. if you get too many xruns try increasing frames value.
7-select inputs and outputs and rock on…

Good luck.

Thanks for the reply JMac

Yes I’ve been trying that too, and again, no problem with audacity, but jack still doesn’t start i get the same error message…

Something must be off…reinstalled it again, made sure i don’t have another compiled version of Jack etc…the strange thing is, before i tried to configure jack to recognize the usb device H2, it started ok…ardour just wouldn’t play any sound…but now whatever I do Jack refuses to start.

Someone got the same problem? I’ve been following some threads throughout the web but i’m still lost…


I use the h4 recorder with quite good results.

I use the internal soundcard as output device tho. Setting set -n2 to -n3 is said to be better with usb audiocards.

Also remember to set the same sampling rate to jack as the zoom :slight_smile: