Ardour does not play after audio export

It is annoying to found that ardour does not play after an audio export. This happens to ver. 2.8.10 . I am on Ubuntu 10.04.I don’t remember a problem like this in earlier versions of ardour . Is this a bug?.After exporting audio the play head refuses to move, but work normally if ardour is restarted. Has anyone encounter this problem?

     However, the problem vanishes,when the "auto return" button is activated and the sesson is saved once more,if it is not saved. Also, there is no problem in sessons, opened with "auto return" already activated. 

   BTW, I have tried this with Ubuntu 9.10 in the same box and with both of these versions of Ubuntu in another machine.

   I just wanted to know, whether this behavior is normal.Thank you for your answers.

I discovered this issue also recently, same thing happens after exporting in 2.8.10. Never happened to me before.

yes, here too.
exporting a region, by rightclicking on the region->region-name->export, everything ok, but exporting a session or a range from the main menu->session->export, the exported file is ok, but no way to start the transport after it.
when the session is restarted, everything ok, but if exporting again, transport is broken…


there were no changes in 2.8.10 compared to 2.8.9 that would have any impact on this, and even 2.8.9 didn’t have anything obvious compared to 2.8.8. it is very important that anyone with this issue mentions the version of JACK and which JACK backend they are using, along with the backend’s backend (so to speak) version (e.g. which version of ALSA or FFADO etc). I strongly suspect that the error is there rather than in Ardour.

here is my part:

jackdmp 1.9.6 from sidux repo
alsa 1.0.23 sidux repo

in 2.8.8 we had this fix/improvement:

Region exports and bounces now use region fade in and fade out curves.

but the region export works now too…

i reinstalled my system about 2 weeks ago and i do not remember which alsa version i was using before.


On mIne:

ALSA 1.0.20 (Karmic Koala’s default)
JACK 0.118.0 (Self compiled)
qjackctl 0.3.6 (Self compiled)

Thank you for responding,

My setup

             ardour 2.8.10 compiled from source
            Jackd 0.118+svn 3796-1 from ubuntu repo
            alsa base ubuntu3 (as found in synaptic)

one more thing. Again, there is no problem if the sync source is selected as JACK, which leads me to think,the problem may somehow related to jack, as Paul suggest.

@Paul: Can you please suggest me of something like, jack updating / alsa version selection,etc. to try. Thanks.