Ardour displays bold font as squares

hello I’ve installed Ardour 5.5 on Fedora 25; when I start Ardour some parts of the interface aren’t readable and are displayed with empty square characters instead; It looks like it’s related to the bold letters only… see screenshot for what i mean please:

any idea of what this could be?

I use apples san francisco font as my system font, but while using lots of other software i nowhere see this issue besides Ardour. (if i’m correct i didn’t have this problem with ardour and the same system font a few months ago)

thanks for your input.

anyone, please?

We’ve seen similar issues in the past with missing libpango modules (depending on font and encoding)
Is this Ardour from Fedora, a self-compiled version or a binary from

it is a binary from thanks for the hint, I’ve installed pangomm and pangox-compat and the squares are gone and i get proper bold font rendering. (not sure if it wasn’t solved by something else I’ve installed in the meantime, but fact is that it’s solved now :slight_smile: thanks!

That fix should not have affected anything. Glad it is working for you now, but …

Hello, I’d like to note that Yesterday I’ve freshly installed Fedora 26, followed by a few probrams and the clearlooks theme engine to fix the theming(white buttons on white text) on Guitarix, and then installed Ardour. Now I’m facing the same issue as described above again, the first dialog when starting Ardour again shows the squares instead of bold text. However, pangomm was already installed and after installing pangox-compat the issue remains.