ardour creating its own noise after starting audio file

Using Mandriva 2009.1. Ardour imports audio file just fine. Press play audio file plays just fine, at first. Then Ardour starts making its own “white noise” type sound, which is not in the audio file itself, and the noise starts low volume then increases in volume as it is allowed to play. I have to kill ardour to stop the horrific noise. If I put in a plugin in the post fader position, the same noise starts immediately. This is a single stereo audio file, 44100hz, 16 bit, premastered with no clipping or other distortions in the file itself. Ardour is creating the noise itself. Anyone else have this issue or know how to fix it ? John in KC, Missouri

I’m guessing you have some plugin that causes the noise. Try disabling all of them and see if it goes away. It might also be some feedback loop or something.

It actually does it with no plugins running at all. I have pulse audio disabled thinking that might be the problem, but it does it with pulse audio running and disabled both. The file plays fine it Audacity, so I’m confounded as to what is causing this in Ardour. Jack it running fine with 5.8 seconds latency, no Xruns, etc. I’m scratching my head as to what this might be. I thought about the feedback loop too, but I’ve checked the mixer settings for the soundcard and nothing should be doing that. I have a soundblaster live 5.1 card. Old but still seems to work great in Linux. Thanks for the reply, I do appreciate it. John

Hmm, what if you play it in Audacity, with Audacity in Jack mode or in Alsaplayer/Jack? Perhaps Jack is causing something.

FWIW Soundblasters aren’t recommended for real audio work since they resample everything to 48kHz internally.

I agree about the sound blaster, but financially it’s the only option I have for a while. I’ll try the Jack options you mentioned. Thanks

UPDATE: Tried running Audacity with Jack running. Not a single problem. It seems to be tied to Ardour somehow, but I’ll be da*ned if I can figure out what would be the cause of this. Mandriva 2010 is coming out first week of Nov. I’ll do a fresh install and see if that helps. Guess I’m stuck with Audacity for now. CRAP ! I like Audacity, don’t get me wrong, but it and Ardour are two different beasts with two different objectives. (sigh)

Does it happen with any file or just that specific one?

Any audio (wav) that I import into Ardour.

What version of ardour do you have? And have you tried any older or newer versions?

I have found a similar problem with some creative sound cards.

To solve, I changed p=3. in stead of 2. It is a jack - ardour - creative combination issue as far as I can tell. The same system runs flawlessly on a RME hammerfall card, using all 18 in and out channels simultaneously.

QHarley, This sounds very interesting. I’m not clear as to what p=3, instead of 2 is. What is the “p” you’re referring to ? It sounds like you have the answer to my problem if you could explain the “p” is that you are changing the value of. Thanks.

I think he means Periods/Buffer in your jack configuration (eg qjackctl)

Okay, tried that. Jack won’t run with Periods/Buffer at 3. Thanks everyone for trying to help. What an odd thing. Cheers, John

Peder had the clue that fixed this problem for me. I set everything to 48000 instead of 44100. Found a piece of freeware called r8Brain to resample my audio file from 44100 to 48000. Jack at 48000, Audacity at 48000. Bingo ! No noise with or without plugins. So I guess for Soundblaster live cards the key is 48000 and then resample the finished project to 44100 for cd. Thanks everyone, John

@zenbrowncoat: for sample rate conversion the tools of choice are sndfile-resample or sox, both of which are open source, free of charge and better quality than r8brain. Both will be available using standard Mandriva software install tools. Just a FYI.

In my Alesis io4 (which has a switch for 24 bits or 16 bits mode) the problem get solved when I switch it to 16-bit and restart. Then I reconfigure Jack (trough Cadence) to have 4 inputs and 4 outputs (instead of 2 and 2, because in 16bits-mode the 4 chanels are available for recording) and the interface just works fine.
The problem appears as it also get solved in Ardour and Audacity and I would expect in any other software, by using 24-bits or 16-bits. I would say it has something to do with conections made through jack and Bit-depth, but no idea how to handle bit depth through Jack. Any idea?
I’m using DreamStudio 12.04.3 LTS with kernel and pulseaudio 1.1 and I have found problems with this Alesis io4 interface in the past with distros with relases below 12.04 (like UbuntuStudio, Ubuntu and KXStudio) perhaps because of ALSA driver or Pulseaudio.
I hope this information to be valuable to others :slight_smile:

I’ve found something similar when importing 16-bit files that I’ve rendered (with dithering) into a new session. I assumed that it was the dithering noise - if my understanding of how you would convert a 16-bit file to 24-bit or floating-point is correct, that noise would be audible because it’s now affecting the 9th bit of each 24-bit sample, as opposed to the bottom bit of a 16-bit one (i.e. at about -96dB). So I just don’t do that any more. This is based on the assumption that you convert a 16-bit sample to a 24-bit on simply by adding 8 bits of zeros at the bottom end (i.e. the converse of how you would convert 24 bits to 16 without dithering), because scaling the 16 bits to 24 would change the dynamics.


I assumed that it was the dithering noise…

Think of increased bit depth / resolution as effectively extending the lower limit of dynamic range e.g. below 0dBFS.

Think of increased bit depth / resolution...
e.g. the available dynamic range is greater for greater bit depth, but your 0dBFS ref should still be the same.

Yes, that’s how I do look at it 0dB (the top bit) stays the same, as does the bottom bit (-96dB in 16-bit) and everything in between, but the noise floor drops from -96dB to -144dB, meaning that the dithering (at -960B to -96dB) becomes audible in quiet passages. And I think it’s likely that this is what’s happening for the OP, particularly since he says the noise goes away if he plays it in a 16-bit setup.

Or were you correcting something I’d said? I don’t see a difference.

Maybe I misread your original post - when I read it (quickly) I thought you were implying that dither at the original noise floor [or some kind of signal, which just happens to be noise] at -96dBFS would somehow become substantially louder / or more noticeable if you increased the bit depth / resolution to 24Bit.