Ardour crashes on startup

If I start it from the Gui I can get the new/open session dialog, but it crashes when I try to make a new session. My terminal output is below:

msp-003407:MacOS bbergstrom$ ./Ardour2
Ardour/GTK 2.8.2
(built using 5396 and GCC version 4.0.1 (Apple Computer, Inc. build 5367))
Copyright © 1999-2008 Paul Davis
Some portions Copyright © Steve Harris, Ari Johnson, Brett Viren, Joel Baker

This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
loading user ui configuration file /Users/bbergstrom/.ardour2/ardour2_ui.conf
ardour: [WARNING]: Unable to find UI style file . Ardour will look strange
ardour: [INFO]: Removed open file count limit. Excellent!
ardour: [WARNING]: no MIDI ports specified: no MMC or MTC control possible
ardour: [INFO]: Apple VecLib H/W specific optimizations in use
ODD: variable IO config for aufx - JASb - ElCa
ODD: variable IO config for aufx - mrev - appl
ardour: [INFO]: looking for control protocols in /Users/bbergstrom/.ardour2/surfaces/:/usr/local/lib/ardour2/surfaces/
ardour: [FATAL]: cannot find icon image for fader_belt.png

I am running OSX 10.5.8 and this happens with jack running or not.

EDIT: Noticed you were running form the command line. In that case you HAVE to run the shell script, not the Binary itself. I can’t remember the naming off hand. We typically don’t test running it in this fashion that I am aware of.

Second thing, are you on PPC? If you are did you unzip using StuffIt or did you let the browser unzip it for you(Uses BOMArchiveHelper)?


the only way to run an OS X bundled application correctly from the command line is to use the “open” command. You cannot invoke any component of the bundle and expect it to work.

Sorry, I should have been more clear. The new/open session dialog comes up when I “open” the application. It crashes upon creating the new session.

I tried to go in using terminal and dot-slash(./Ardour) to run it and see the error output. I was not aware this was not a good idea on Mac. I am still new the the OSX world and am used to running Ardour on Linux. So, ignore that error output.

Does Ardour keep a log of the errors so I can see what is happening when the program crashes?

I am on an Intel based MacBook Pro.

Yes, two things you can do…

First it isn’t a bad idea to get on IRC and chat with us about this there, but aside from that…

On the Mac you can access the console to read the output of Ardour by going to Applications>

You can clear it out, launch ardour until it crashes, and that will give you the console output.

Also if it crashes you should get a dialog asking if you want to report it to Apple. While I don’t believe that would do any good, if you click on I believe it is the ‘Report’ button it should bring up a backtrace that we would need. You don’t need to send it, just get the text from there.

Again it probably isn’t a bad idea to hop on IRC, put the console log and crash report on pastebin, and give us a linkt here so we can talk through it, but at least give us a link to them here to see them.


My crash report is here

The error I am getting in Console Messages is:
([0x0-0x21021].org.ardour.Ardour2[527]) Exited abnormally: Bus error

I went and looked again at the OSX help page on this site and decided to try the tip to remove .fontconfig and have ardour rebuild the fonts. It worked!

I have successfully started a new session. :slight_smile: Thanks for your patience guys.