Ardour Cound not playing properly

So I upgraded my regular Maverick OS to the version for Ubuntu Studio so i didn’t have to manually install all the programs with it. before i did this Ardour worked great, i got nice quality playback and I could do work with Xjadeo since I do audio for videos with it.
Now that the system is updated Ardour loads painfully slowly and plays back all recordings distorted, almost like there was a pulse to it but not sounding at all like the file should (played in other programs these files sound fine). The sync through JACK to Xjadeo isn’t working right either when I start playback the film doesn’t move through frames it just stays where is was; when i stop playback it jumps back forward where its supposed to be; this is not how the program is meant to work because I can’t see where i am in the film to set music to it if I can’t see the moving film!
I’ve synced Xjadeo with Rosegarden separately and it worked fine meaning the problem is in Ardour and not JACK or Xjadeo. I’m not sure if I configured something wrong or if its a bug.
The Problem isn’t processing speed either because it wont even play a 10 second clip without any editing done to it properly.
I’ve been playing with it for a few days and I’m stumped, any ideas?

With each new Ubuntu release, at some point I attempt to install Ubuntu Studio just to see what it’s like. So far I’ve never managed to get it to complete the install and / or do anything remotely useful on any of the machines I use (not that it can’t be done, just that I don’t have the patience - I don’t see the point in using a dedicated audio distribution and then having to spend a significant amount of time and effort configuring it to do audio). Perhaps I’ve just been unlucky with it.
That said, the machines I’m currently using for developing plugins etc run 10.04 LTS with minimal modifications and work just fine. If you want to use a dedicated audio / video distribution I’d recommend something like AVLinux:

or dream studio:

I feel the same way about ubuntustudio, stock debian with a rt kernel even works better than ubuntu studio , avlinux5.0 is a great audio distro.

that solved it, I uninstalled the Ubuntu Studio leaving Ubuntu by its self and re-installed ardor through terminal and its very happy now, Thanks!