ardour could not start jack

there are several reasons:

1 you requested audio parameters are not supported.
2 jack is running as another user.

im new to linux and have not even used this program yet as it doesnt even open?

any ideas???

without any details it could be had to say. do you even have jack installed?

look for qjackctl (spelling might be wrong)

try starting jack from there and see what happens.

what distrobution are you using?

i know the problem but have no idea on how to fix it.
yes qjack is installed.

what i have done is installed calf studio plugins from their website via terminal but not realised that i then have to go through
a heap of other commands to compile everything together for it to work as explained here- - compile from source! its beyond me coming from windows how to do this.
im used to installing packages or sudo apt-get installs but when i did it that way the software was out of date.
and since installing the files for compiling its messed with something which has caused a conflict with ardour
and i dont know how to revert the process of what i have done, heck i dont even know where all these files go once downloaded…

elementary luna updated to ubuntu 13.10 kernel, i think?

its down to jack not running in realtime as when i turn it off ardour opens fine? so another problem??


If you can’t run JACK in realtime, you most likely don’t have the correct user / group permissions set. You need to make sure the ‘audio’ group has permission to run realtime applications, so you may need to add:

@audio - rtprio 99
@audio - memlock unlimited

to your /etc/security/limits.conf file or your /etc/security/limits.d/audio.conf
file (depending upon where the Ubuntu devs have moved the file to this week…)
After you have done this (or if this has already been done - which it may have been if you installed ardour from your distributions repo) then you need to make sure your username is added to the ‘audio’ group.
sudo usermod -a -G audio username
where username is you user name.
If you log out and back in again (or do a complete restart) you should then be able to run JACK in realtime.

@sheppss: If you are new to linux, it would be best to install a dedicated audio-distro where everything is already configured for RT-audio…

And the audio software would be up to date on apt-get, too. elementaryOS is really one of the worst distros to do this on. It’s made for consumer use, not for any kind of production.

LinuxDsp pretty much has it nailed, not being able to start jack with realtime is due to not being part of the audio users group.

Personally i recomend KX studio though you might want to take a look at the kx studio forums since they have a new dvd image out which may be a bit quirky on some machines, ive not tried to new image yet. if you can get the older image id install that.

Alternativly theres av-linux which is pretty rock solid, though i find it harder to install some software form source due to dependancy issues.

KX studio should work mostly out of the box without much user intervention. However get used to the idea of having to work with a terminal. it may seem a pain in the ass at first, but you will soon learn with enough use of how powerfull a terminal is compaired to a gui.

Once its setup right, you should not have to do anything. it should just work. Though to expect some bugs in ardour as new versions come out. In time they will get ironed out.

i recommend you to read this
Hit download pdf .
its nice book and its free
Chapter one is important to read.

Hi there. I have problem. I don’t see Ardour in ALSA tab, and I can’t connect midikeyboard to Ardour. What I do wrong? I try setup midi preferences, jack options, but that problem still is. Anyone have some solutions? Or some default customs file for Ardour? (a new release of JACK will soon make most of this advice obsolete, but for now …)