Ardour could not connect to Jack.

Hello all,

I installed Ardour about a week ago. Everything was working fine and now I get the following error.

Ardour could not connect to Jack.
Possible reason:

  1. Jack is not running
  2. Jack is running as another user, perhaps root.
  3. There is already another client called “audour”.

What gets me is that it was working just fine and now it is not… grrr

I’m still new to Linux and do not what to go back to Windows. Ardour seems to be the key for audio in Linux.

I’ve looked on this forum and could not see a strait answer on how to fix this. I’ve tried - sudo qJackctl and get the following - sudo: qJackctl: command not found

Please help

make sure there are no other applications that are using your sound system (including a web browser) try closing all other aplications, and reopen jack. do you use qjackctl, or the jack client built into Ardour? if the latter, you might try qjackctl…it will give you more info on why jack won’t start.

bash: qJackctl: command not found

I’ve rebooted and only try and run Ardour and still get the same thing.

keep in mind Linux is case-sensitive, so qJackctl is different than qjackctl. My guess is that it’s all lowercase. It also might not be installed by default. What distribution do you use?

I installed in from the “synaptic package manager” in ubuntu. Also, I’ve tried both uppercase and lowercase, still “sudo: qJackctl: command not found” - “sudo: qjackctl: command not found”

Ardour was working just last night, so I’m now sure what happen seeing that I have not changed anything on my system.

I guess I could un-installed it, reboot and install it again?

Un-istalling it an re-install did not help. This is Jackd up…

jackd version 0.103.0 tmpdir /dev/shm protocol 16

In synaptic, search for qjackctl and install it. I don’t think you need sudo, just type qjackctl. Or select JACK Control from the menus.
Enter the ardour channel for quicker help. Click the link

JACK compiled with System V SHM support.
loading driver …
apparent rate = 44100
creating alsa driver … hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
cannot load driver module alsa
no message buffer overruns
12:29:36.035 JACK was stopped successfully.
12:29:36.036 Post-shutdown script…
12:29:36.036 killall jackd
jackd: no process killed
12:29:36.173 MIDI connection change.
12:29:36.258 Post-shutdown script terminated with exit status=256.

After troubleshooting some more I notice that I could even play .mp3’s on my system. After fixing that problem I was able to lunch Ardour.

I like you thank everyone for helping this linux noobie out…

Thanks a bunch