Ardour causing problems with CoreAudio

I recently subscribed Ardour, and downloaded it to use with my Macbook Air.
However, there are problems with it. I created a project with default audio settings, and when I load it next time it would not let out any sound, and it tells me that the sample rate was wrong.
So I went to the Audio MIDI Settings to set the sample rate into 96000Hz, and so on Ardour (on a new project, in which I used Kontakt 5 AU), and it worked well.
Until one day I found that the sample rate of my computer dropped back to 44100Hz. Glad that I recorded nothing on that project…
And then I thought there was problems, so I went back to Garageband.
And the even weirder thing happened, Garageband failed to load Kontakt plugin.
I went back to that Ardour project, tried deleting that plugin (which I failed, leaving an error message of being unable to identify I/O), and cleared the whole track (which did not help).
I’ve reinstalled Kontakt (and even Garageband) several times, in vain. Kontakt AU still loads happily on Ardour, just doesn’t work on Garageband.
Any way around?