Ardour can't find LV2 plugins un opensuse 11.3 64 bit

Perhaps this question was already answered, but I didn’t find it in the forum.
I’ve tried to instal Ardour from the RPM repo on my new install of opensuse 11.3 64 bits, but the LV2 plug-ins don’t show up in the list :frowning:
Then I’ve tried to compile from source
(scons FREESOUND=1 SLV2=1 , and sudo scons install)
to have the last bits of novelty from Paul’s team, but here also no luck :frowning: no LV2
The strange thing is that the LV2 are in /usr/lib64/lv2/ and are not found and the ladspa are in /usr/lib64/ladspa/ and show up normaly ???

Any idea ?

Ok, self answering… perhaps it can help someone else
Making a soft link do the trick from /usr/lib64/lv2 to /usr/lib/lv2

sudo ln -s /usr/lib64/lv2 /usr/lib/lv2

We generally prefer that you set the environment variable LV2_PATH. It might also be worth filing a bug on this, because it was fixed for LADSPA where we search both /usr/lib/ladspa /usr/lib64/ladspa.

Thank’s, of course the LV2_PATH variable is a more correct solution.

Did not work for me.
Also tried LV2_PATH=/usr/lib/lv2

@antonvdh : do you have any LV2-plugins installed?
Also, you need to start Ardour from that terminal, so in essence you should run something like ‘LV2_PATH=/usr/lib64/lv2 ; ardour2’

Don’t forget to export the environment variable, too.

I have calf lv2 plugins installed

export the environment you mean:

export LV2_PATH=/usr/lib64/lv2

Yeah, the command line should read ‘export LV2_PATH=/usr/lib64/lv2 ; ardour2’
Mea Culpa.

anton@linux:~> export LV2_PATH=/usr/lib64/lv2 ; ardour2

started ardour

opened plugin manager
search for LV2 , invada or calf cannot find anything ??

It is not working for me why?

@antonvdh: Can you be absolutely sure you have LV2 support compiled in? (See the compile options in the original post). If you don’t have LV2 support enabled (or possibly due to a missing dependency) it is not always immediately obvious during the build that LV2 support has not been included (carefully check all the config messages) and the result is LV2 plugins don’t show up (This has happened to me a few times during various different ardour builds… and normally leads to much cursing until I realise which of the LV2 related libs I haven’t installed :slight_smile: although on ubuntu systems this is now made easier by apt-get build-dep

I have no idea if LV2 support is compiled
Just installed ardour-2.8.11-2.25.x86_64.rpm
http://software.opensuse.org/search?q=ardour&baseproject=openSUSE%3A11.3&lang=nl&exclude_filter=home%3A&exclude_debug=true

Try running ‘ardour2 >& Ard.log’. When it has started, exit Ardour and run ‘grep -i lv2 Ard.log’

If grep doesn’t find anything you don’t have LV2 support.

You could run ldd on the ardour binary (not the wrapper script which normally starts it) and see if the output references libslv2. For example on my system (32 bit) with Ardour 2.8.9 If I run:

ldd /usr/local/lib/ardour2/ardour-2.8.9 | grep slv2

I get a reference to libslv2 which indicates that the binary depends on libslv2 and therefore LV2 support is compiled in. The path to the ardour2 binary may be different depending upon your system configuration, but its likely /usr/local/lib/ardour2/ or /usr/lib/ardour2/ (or their 64Bit equivalents)

anton@linux-txrl:~> ardour2 >& Ard.log ( after startup closed it)
anton@linux-txrl:~> grep -i lv2 Ard.log
anton@linux-txrl:~>

No output but also no output on a working ardour with lv2 on a 32 bits system I have.

Did you compile ardour yourself?

Gaah, I seemed to remember it showing something about searching for LV2 during startup, but I was wrong.

OK, this should show you if it supports LV2 or not
grep exec which ardour2 | awk ‘{print $2}’ | xargs ldd | grep lv2

It should produce something like “libslv2.so.9 => /usr/local/lib/libslv2.so.9 (0xb6986000)” if it’s supported.

sorry also no output

anton@linux:~> grep exec which ardour2 | awk ‘{print $2}’ | xargs ldd | grep lv2
anton@linux:~>

which version ardour opensuse 11.3 x86_64 did you install

I only have a self compiled Ardour for openSUSE-11.0 32-bit.

So the conclusion is that your version doesn’t support LV2.

I think your right.