Ardour cannot run on Win10 x64


(Anclarkliu) #1

Hi everyone. I paid for Winfows version and installed Ardour on my Windows 10 x64. But when I run, Ardour stopped itself quickly without any interfaces and error messages. That’s strange.


(Paul Davis) #2

Many people use Ardour on Windows 10 x64. It is actually one of the most common platforms for the program. The issue is system-specific (i.e. it happens on your system, but not in general). This makes it hard for us to provide you with any support - we are an extremely small team and generally there is no Windows expertise here.

But perhaps someone who uses Windows can offer you some advice in figuring out what is going on on your machine.


(Anclarkliu) #3

Thanks for replying!
One way to figure out is finding the log generated. But I don’t know how to get the log. Only if it can generate some logs.


(Robin Gareus) #4

Is this on a non-english system and a user-name that perhaps has umlauts? – in some case ardour fails there.

Check if there’s an Ardour5 folder in %localappdata% (enter that literally in an explorer bar, it’ll expand to C:\Users\YOURUSERNAME\appdata\local, a hidden folder).

Running Ardour from a “cmd.com” or using the debug-version of ardour may shed some light.


(Anclarkliu) #5

My system is a Simplified Chinese Windows.


(Robin Gareus) #6

Perhaps you can create a new user (Windows Settings > Accounts) with a simple ASCII name e.g. “testuser” and see if Ardour runs under that username? There may be more to it though.

Another option is to try a https://nightly.ardour.org/ build (the username issue should be fixed there), but nightlies are not ready for use in production at this point in time.


(Anclarkliu) #7

Yesterday I tried to run Ardour with command line, and I discovered that Ardour really depends on command line.
Without command line tool, there’s totally no way to launch it.
That shouldn’t be what a Windows GUI app do, be honest.


(Paul Davis) #8

Ardour does NOT depend on the command line at all.

Once again, the error you are encountering is a system-specific one. It does not happen to the vast majority of our Windows users.

The question is now: why does it work when run from the command line when it does not work when invoked normally?


(John E) #9

A permissions issue maybe? It’s not likely - but worth trying…

anclark - I’m guessing that (up until now) you’ve either been launching Ardour from a desktop icon, or maybe from an icon on your start menu. Maybe try these steps as an alternative:-

  1. Open Windows Explorer and navigate to the same folder you used when you ran Ardour from a Command Line. It’ll probably be something like C:\Program Files\Ardour5\bin
  2. You should find the Ardour program quite near the top of the files in that folder.
  3. Double-click on it and see if it’ll launch
  4. If it doesn’t launch, right-click on it and select Run as administrator

Let us know if any of that helps.


(Anclarkliu) #10

Invoking normally with Administrator permission (“Run as administrator”) still doesn’t work. On my system, Ardour can only be run with command line tool. Still strange.


(John E) #11

Does your Windows 10 desktop have a launch bar at the bottom? If so, what happens when you try to start Ardour? Does it appear briefly on the launch bar and then disappear? Or does it stay on the launch bar? Or doesn’t it ever appear on the launch bar?


(Anclarkliu) #12

Ardour doesn’t appear at the launch bar at all. And in task manager, it only appears for a while, then terminates.


(John E) #13

That sounds like there’s some configuration file missing (or even a DLL). Maybe one of the other members can suggest a file that’s needed when running normally - but which wouldn’t be needed when running from a Command Line (I must admit, I can’t think of one…)

If that’s not the problem I can only suggest 3 things:-

  1. Uninstall Ardour and re-install it.

It you’re running from a desktop shortcut (and Item 1 doesn’t help…)
2) Right-click on the desktop icon and click the ‘Shortcut’ tab. Make sure that the ‘Start In’ folder is the same folder where you installed Ardour.

If the above looks okay…
3) Click the shortcut’s ‘Compatibility’ tab and experiment with the settings (or run the ‘Compatibility Troubleshooter’ if there’s one in Windows 10).

Just out of interest… is Harrison Mixbus also installed on your PC ?