Ardour cannot find source files after copying session [SOLVED]

I copied a sessions folder from my Linux Desktop (L1) to Google drive and then downloaded the whole folder onto another Linux machine (L2), but when I open the session in L2, Ardour complains that it cannot find the source files (both wav and mid) in the listed folder. Yet they are there, in the “audiofiles” folder.

I tried reselecting the guilty “audiofiles” folder from the drop down menu, to no effect.
I also tried opening the session without the source files then reimporting them, but Ardour actually copies the file in the same folder and appends a suffix to the filenames, so the tracks are still without the proper sources.

Any idea? Everything worked fine on the first desktop. The only thing I can think of is that the audiofiles folder path has spaces.

Is it possible you moved from a case insensitive to case sensitive file system? Or did the case of the files change at all going through google drive?

Seablade

EDIT: Fixed insensitive->sensitive direction that might possibly cause such an issue.

SOLVED. Thanks for putting me on the right track.

The issue is the % character that Ardour introduces in the file name when it splits a stereo channel into right and left. Apparently Google Drive strips that character when it zips the files for download, and then Ardour is lost. Interestingly, Drive does not remove the % if you download a single file, it’s the zipping that does it. so the tedious solution was to download 88 files one by one…

Edit: some midi patches were messed up as well, because Drive had replaced the “:” (semicolon) with an underscore. That was easy to fix with a rename command (I guess a smarter man could have used the rename utility on the .wav files too, but that was beyond me)