Ardour bus mono or stereo routing

To put it simply, I have one or more single tracks, I click at the bottom of the mix slice to remove the “Bus Master” outputs, and connect to the desired bus inputs. If I created a stereo bus, it is present in the drop-down menu, if it is a mono it is not there. Of course the mono bus is in the routing grid. There is a logic in the thing?
C’est google qui a fait la traduction…

The track output is set to the number of channels the master bus has at creation. When you remove the output to the master bus, this does not change. With the routing grid you can remove the second output and from that point on the mono buses will also be displayed. I do not know if setting the session or preferences to not auto connect to master would change this. The drop down only shows compatible inputs, so if the output is stereo, it will only show stereo inputs.