Ardour and ZynAddSubFX [SOLVED]


(Antonio de Almeida) #1

Hi. I’m having a trouble with Ardour and Zynaddsubfx. Some of my old songs uses a Zynaddsubfx version that was inside the Carla Host. Today a local label have interest in release two of this old songs, and I’m trying to re-export the stems to mix and master again. But the Ardour says:

[ERROR]: Found a reference to a plugin (“http://kxstudio.sf.net/carla/plugins/zynaddsubfx”) that is unknown.

  • I have the Zyn-Fusion 3.0.3 installed from the KXStudio repositories (zynaddsubfx-git package) that works nice.

  • I tryed to install the zynaddsubfx (without -git), bu this do not work.

  • I tryed to open the .ardour XML files to find out how to replace the references to try to open the patches with the new version; I used the “find and replace” function from a text editor to change the “unique-id” variable from “http://kxstudio.sf.net/carla/plugins/zynaddsubfx” to “http://zynaddsubfx.sourceforge.net” and this worked, the old plugins was replaced by the new ones, but without the patch, only with the init preset.

Please, there is a way to open the patches with the new plugin or other workaround? I just need to export two songs or save the patches from the old Zyn, to the new one.

I appreciate any help with this issue. Thanks.


(Robin Gareus) #2

“carla/plugins/zynaddsubfx” was an unofficial plugin based on zynaddsubfx 2.5.x, provided by a 3rd party (kxstudio). zyn-fusion is now an official plugin and based on zynaddsubfx 3.0 (major version difference).

You might be able to also update the plugin’s custom state (manifest.ttl and state.ttl for the given plugin in the session’s plugins/ folder). But even then it’ll probably not be the same result since zynaddsubfx changed.

To export an old session, ideally use the old plugin.

PS. just now on IRC, falktx said

the state is the same, pretty much
the carla version has a few params, which might get weird for zyn, but I think wont conflict
replacing the uri in the preset should work, if one replaces the URI of the state type too
in state.ttl, urn:carla:state needs to be urn:distrho:state

PPS. Create a new session, load new zyn, save and compare the generated state.ttl filles. Perhaps just copy zyn’s embedded XML state.


(Antonio de Almeida) #3

Thank you! This solved the problem.

The steps are:

One of the projects that I have to recover uses 17 instances of this old plugins. The process is simple, but this will take some time to finish. :sweat_smile:


Is there a way to get ZynAdd settings from the ardour session file?
(Les Partages De Barbu) #4

Hello

Same issue for me after migration from legacy zynaddsubfx to zynfusion on kxstudio. But as I used the lxvst zynaddsubfx plugin (not lv2).
I replaced all written above and then, in my .ardour file, I changed lxvst by lv2 .
This does not allow me to recover patches.

Need a little bit of your help please
Thanks a lot
Barbu